Hi all, I'm from Italy. I've got an OX 1000x1500mm since about two years.

Hi all, I’m from Italy. I’ve got an OX 1000x1500mm since about two years. First thing I’ve changed is the belt clamping system, I don’t really like to have a t-nut with a screw pulling on the belt, so I’ve made a new system fixed to the machine frame. I’ve done several works, most of them are vinyl clocks, but since about one month I’ve seen a bad error when the machine is cutting (see attached picture). It seems that motors are losing steps but, I’ve tried to mount a drag bit with a ruler on the work table, and the motors movements are correct. I don’t really know how to figure out what is causing that problem.
If I made a circle, it didn’t come round at all but if I made a square it comes out perfect!
Any suggestion?


I have 3040 with ball screws, but I had similar issue and it turned out that the coupler on X axis motor was a kind of loose. Tightening the screw solved my issue. Ox is belt and pulley based, so I would make sure pulleys are properly fastened to the motor shafts.

First rule of thumb if you think you’re losing steps: slow down.

Ok now, I’ve spent the last days double checking everything, starting from eccentrics then belts and pulleys. The gantry moves smooth without belts if I move it by hand, the wheels are not too tight. The belts are correctly tensioned and clamped. But the problem remains just on the X axis. I’ve reduced the speeds and accelerations but the problem is still there. Now that all the mechanical parts are checked without fixing that problem, I’m about thinking that it comes from the electrical/electronic part. Maybe from the X axis driver, is it possible that the driver shut down just a fraction of second and loses steps?
I’ve made a square of 15x15mm with an 1mm endmill starting from top right and going counter clockwise, the internal measure is exactly 15x15 but I still have that problem on the starting point

Don’t really know what else could be

Did you find a solution? I also own an OX and im having a similar problem…

FYI Fabio hasn’t logged into discourse since we moved conversation from Google+ so he won’t see the question.

The general idea is that this normally means that something is loose, and you need to check everything because you could have more than one thing loose. You have to go through methodically through every connection on the machine… If you have one loose axle screw, you quite likely have another one somewhere. And you have worn wheels; check preload. Probably not spindle bearing play; you would probably have noticed that otherwise.