hey guys im having an issue uploading code to a Wemos D1 mini pro,

hey guys im having an issue uploading code to a Wemos D1 mini pro, well all of them really. i keep getting this error:
warning: espcomm_sync failed
error: espcomm_open failed
error: espcomm_upload_mem failed
error: espcomm_upload_mem failed

i thought it may have been the code i wanted to upload but i get this error with all programs, even the basic arduino blink sketch :confused:

Try grounding gpo0

I’ve gone through this too :slight_smile: There are a few things that could need changing, or at least checking, here’s my setup (depends on the board, if it’s a clone it’s a bit hit and miss as the models are often badly named, in my experience):

Tools>Board>WeMos D1 R2 & Mini

      >FlashSize> 3M Spiffs (this is the mem issue I had, select the right one #trialanderror)

      >CPU Frequency>80Mhz

      >Upload Speed>921600 (I found this stops any time out or mem errors)

Other things, check your port and check that the software can see the device by going:

Tools>Get Board Info

That way if it can, you get a pop up stating the board (often unknown, that’s okay) details.

Hope that helps!

Let me know if that doesn’t, I have a few other ideas… The above was my learning curve last weekend!

I think I had this, when I tried the wrong USB port or sometimes one upload fails, the next ones are ok again. But definitely not a persistent error.


@iamjameshannam ill give those a shot :slight_smile:

@Stefan_stelb_Le_Bret i tried all my usb ports and uploaded several times with no luck. Also different usb cables. Theres only 1 port in arduino to choose from so im pretty sure its the right one lol. Idk man i havent had this issue with ESP8266 before. I did with the Attiny85 breakouts thou. But those were bricked

Verify reset method set to Nodemcu and not ck

@Gordon_McLellan where would reset mode be?

@Cristian_Martinez it’s in the Arduino IDE, might be called reset method? Been a while since I’ve been in there.

Dont see anything like that on there

Im gonna try reinstalling Arduino and see if that fixes it

If you get the error message error: espcomm_open failed sometime is is your PC. What I have found is on a windows 7 64x that you must make sure you download and install the the UART USB driver after you install arduino.

Next, make sure you have the correct port set and the settings depending on which model you are using.
For me I use the ESP8266MOD ESP-12E NodeMcu V3 module so my setup this.


I did a reinstall of arduino with the newest version. I restarted my laptop in case that was the issue. I still cant load a program to any of my boards :frowning:

I remember windows updated recently. Perhaps thats what broke it?

@Cristian_Martinez Might be because I had to install the UART drivers after Arduino and then worked perfect.

Ill give that a shot when i get home

@Cristian_Martinez - I was having the same problem at times. Check the Programmer setting in the Arduino IDE. It should be AVRISP mkll and not AVR ISP. I know you use the ATtiny85 which uses a different Programmer setting and so does the Arduio Uno and the Teensy MCUs. This solved my problem.

Also, check the device manager in Window when your Wemos D1 mini pro is connected to your computer (assuming you have a Windows computer). Check to see if you have the correct drivers for your USB to UART chip that the device manager shows as the USB to UART chip on your Wemos D1 mini pro. Here is a web page discussing this:


@Ken_White thanx! Ill give that a shot!

@Ken_White im no expert at this but im pretty sure its not supposed to say RAMPS…
missing/deleted image from Google+