Hey everyone, Recently, I've been working on a lot of FastLED projects on Adafruit

Hey everyone,

Recently, I’ve been working on a lot of FastLED projects on Adafruit DotStars, and the library has worked really well (I love the HSV support). However, I recently embarked on a project using:

However, despite my efforts the LED’s always show up in all-white, full brightness with no animations. Here is some sample code:

#include <FastLED.h>

#define NUM_LEDS 16
#define DATA_PIN 0


void setup() {
pinMode(1, OUTPUT);

void loop() {
// Turn the first led red for 1 second
leds[0] = CRGB::Red;
digitalWrite(1, HIGH);

// Set the first led back to black for 1 second
leds[0] = CRGB::Black;
digitalWrite(1, LOW);


In this case, all 16 lights turn on white, full brightness. No red, no animation on the first LED. Since you can’t do serial communication, I have the built in LED on the Gemma flashing in the loop code - this still works successfully, so the code works. Also, if I change the number of LED’s in the addLED’s call, it only lights up the corresponding number. Also tried setting NEOPIXEL to WS2812B, but looked at FastLED.h and saw that they all lead to the same controller anyways.

Even weirder - the Adafruit Neopixel Library works just fine - but sadly misses out on all of the sweet features of FastLED.

I’m pretty stumped at this point, am I missing something?

Use the FastLED3.1 branch for this.

Awesome @Daniel_Garcia , it worked! Just curious, do you have any ideas what’s was up here?

Yeah, the asm code in FastLED3.0.3 for the gemma was a bit too fragile and different versions of gcc would regularly mess it up - I overhauled it pretty significantly a month or two ago on the 3.1 branch.

Cool, thanks so much!