Hey Chilipepprs, I was trying out CP for an automatic probe/leveling solution on my

Hey Chilipepprs,

I was trying out CP for an automatic probe/leveling solution on my GRBL shapeoko, and it seems to work great, the only issue i am having, is that all the probes have a z position of 0.000.

Now I feel this is a symptom of another problem, which manifests itself in my DRO axes window. My Y and Z axis show NAN.000 and my X axis shows my current Z position, so I think that is how I am not getting any useful probe data. Everything jogs correctly, the right amount in the proper direction, it is just the numbers in the display

Thanks,

I have a screenshot for any interested parties

          else if(msg.indexOf("MPos:") >= 0){
                //remove all unnecessary formatting from 0.8abc & 0.9f, split by comma to access each value//
                var rpt_array = msg.replace(/\[|\]|<|>|MPos:|WPos:|\n/g, "").split(","); 

GRBL: AltOnRecvLine: <Idle,MPos:-4.998,-1.999,6.000,WPos:-4.998,-1.999,5.000,Buf:0,RX:0>

Alright, thanks to a very helpful and patient @jlauer , I got my problem sorted.

In the GRBL settings I needed to change $10=3 (status report mask:00000011), which I had unintentionally changed to =0.

Looks great now. Thanks again!

@Jarret_Luft we found the problem. He had $10 set to have Planner Buffer and RX value be reported. Your regular expression seemed to fail on that. Here’s a suggestion for an alternate RegExp.

// find if mpos: is in string with 3 comma delimited floats
// the slash i is for case-insenstive match
if (msg.match(/mpos:(.+),(.+),(.+)/i) {
var x = parseFloat(RegExp.$1);
var y = parseFloat(RegExp.$2);
var z = parseFloat(RegExp.$3);