Hey All I'm having a hell of a hard time connecting to my azteeg

Hey All

I’m having a hell of a hard time connecting to my azteeg x5 mini. If I turn it off (after making some config changes, or just to shut down the printer for a bit) and then turn it back on and try to connect, and it just wont. I’ve tried removing the USB cable, not removing the USB cable, removing the USB cable before turning it off and reconnecting it after I turn it back on. I’ve tried the reverse, where I turn it off first, then unplug and replug the USB cable then turn it on, and combinations of this. Still, it’s really trial and error when it comes to connecting, and it seems it only connect about 1 in 5 times.

Has anyone else run into this issue? It’s been happening since the very beginning, and I’m getting sick of it.

Well azteeg boards I have no experience with but have you tried lowering the baud rate? Have had trouble with some laptops that they can’t keep up to the default baud rate and communication is troublesome or nonexistent until I lower the baud rate.

I had the exact same problem with my smoothieboard and the USB controller inside of my desktop motherboard. I would have to restart my computer to be able to reconnect after a power down on the smoothie. I replaced it with an aftermarket USB controller in a PCI slot and that fix the problem for me.

The funny thing is I don’t have similar issues with my azteeg x5 on the same computer.