Help with auto level milling too deep


I am having an issue with auto level when it comes to actual milling.

I run the test probe and auto levels fine. I then send the auto leveled Gcode to the workspace and it says “no units found in Gcode,” so I tell it to use mm. Then when I run the Gcode, the spindle speeds up and the vbit immediately proceeds to plunge down through both the FR-4 and waste board.

I have run this Gcode before without the autoleveling so I know the original code is not the problem.

I thought perhaps it might be related to zeroing out before auto leveling? I have been zeroing all three axes first, then returning to zero after auto level is complete.

I’m using the jpadie workspace.


Any chance yo could post any screenshots to help show the before and after Gcode?

I’m working on it at my library makerspace so I’ll try to get some screenshots the next time I am there.

But do I have the procedure right, should I be zeroing all three axes before auto leveling and then returning to zero after leveling is finished?

Yes, zeroing out is the right approach. The auto-level also does it’s own zeroing out when it does the first point. That becomes it’s reference for all subsequent points.

Here is the original Gcode and the file with the auto-level added.

Seeing a Z of -34 is wrong. That would shove 34 mm into the workpiece. Are you using work coordinate systems or something like that such that it would throw off the Z values? You can see on line 24 it goes to Z 0 correctly.

What I really need is a screenshot of chilipeppr to see the 3d rendering of the auto-level. I bet that too is showing -34 roughly as the range of the points.

N24 G1 F80.00Z0.0000 (al new z)
N25 G0 Z1.9990 (al z mod 1.999)
M3 S10000
N27 G0 X2.4438 Y3.4351 Z-34.2447 (al new z)

I couldn’t get it to display the 3D render from the cached file, but I have the probe data and screen shots of the final matrix, if that helps.

I’m just using the default coordinates as far as I know.

Yeah, that’s crazy wrong. Each location should be in the 0.0xx range. When you watch it do it’s thing, when does the number jump so high? Are you using an electronic touch plate? Or a pressure switch?

I can watch for the jump in numbers the next time I run the test. I’m new to auto-leveling and honestly was just excited to see it working.

I’m using the same board that I am trying to mill. I initially milled one without auto-leveling and was hoping to make another using that feature to create a nicer looking board, as the first one came out a bit crude looking.

Could it be a problem with the board I milled?