HELP :-O I'am lasering and during the process I realize my results are to

HELP :open_mouth:
I’am lasering and during the process I realize my results are to small…
I ahve no Idea why…
elements, that are supposed to be 3 cm are only 2,5cm
and 25 cm comes out as 20 cm.

its some sort of scaling. does anyone have an idea how this can happen and how I can change this ?

“__version”: “4.0.991”,
“__selectedProfile”: “new-3”,
latestRelease": “2018-06-23T08:36:10Z”,
“showMachine”: true,
“machineWidth”: 520,
“machineHeight”: 600,
“machineBeamDiameter”: 0.1,
“machineBottomLeftX”: 0,
“machineBottomLeftY”: 0,
“machineFeedRange”: {
“XY”: {“min”: 1, “max”: 50000},
“Z”: {“min”: 1, “max”: 50000},
“A”: {“min”: 1, “max”: 50000},
“S”: {“min”: 0, “max”: 30000}
“machineXYProbeOffset”: 0,
“machineZEnabled”: false,
“machineZMatThickness”: 0,
“machineZToolOffset”: 0,
“machineZStartHeight”: “”,
“machineZProbeOffset”: 0,
“machineAEnabled”: false,
“machineBlowerEnabled”: false,
“machineBlowerGcodeOn”: “”,
“machineBlowerGcodeOff”: “”,
“pxPerInch”: 300,
“forcePxPerInch”: false,
“dpiBitmap”: 300,
“toolGridWidth”: 520,
“toolGridHeight”: 600,
“toolGridMinorSpacing”: 10,
“toolGridMajorSpacing”: 50,
“toolSafetyLockDisabled”: false,
“toolCncMode”: false,
“toolImagePosition”: “BL”,
“toolUseNumpad”: false,
“toolDisplayCache”: false,
“toolUseGamepad”: false,
“toolCreateEmptyOps”: false,
“toolVideoDevice”: null,
“toolVideoPerspective”: {“enabled”: false},
“toolVideoLens”: {“a”: 1, “b”: 1, “F”: 1, “scale”: 1},
“toolVideoFov”: {“x”: 1, “y”: 1},
“toolVideoResolution”: “720p(HD)”,
“toolVideoOMR”: false,
“toolVideoOMROffsetX”: 0,
“toolVideoOMROffsetY”: 0,
“toolVideoOMRMarkerSize”: 20,
“toolWebcamUrl”: “”,
“toolFeedUnits”: “mm/min”,
“toolTestSValue”: 1,
“toolTestDuration”: 0,
“gcodeStart”: “G21 ; Set units to mm\r\nG90 ; Absolute positioning\r\nM4 S0 ; Enable Laser/Spindle (0 power)\r\n”,
“gcodeEnd”: “M5 ; Disable Laser/Spindle\r\n”,
“gcodeHoming”: “$H”,
“gcodeGenerator”: “default”,
“gcodeToolOn”: “M3”,
“gcodeToolOff”: “M5”,
“gcodeLaserIntensity”: “S”,
“gcodeLaserIntensitySeparateLine”: false,
“gcodeSMinValue”: 0,
“gcodeSMaxValue”: 1000,
“gcodeCheckSizePower”: 9,
“gcodeToolTestPower”: 9,
“gcodeToolTestDuration”: 0,
“gcodeConcurrency”: 2,
“gcodeCurvePrecision”: 0.1,
“comServerVersion”: “4.0.127”,
“comServerIP”: “localhost:8000”,
“comServerConnect”: false,
“comInterfaces”: [“USB”, “ESP8266”, “Telnet”],
“comPorts”: [
“comName”: “COM4”,
“manufacturer”: “”,
“pnpId”: “USB\VID_1A86&PID_7523\5&4E27C13&0&4”,
“locationId”: "Port
“vendorId”: “1A86”,
“productId”: “7523”
“comAccumulatedJobTime”: 3196,
“connectVia”: “USB”,
“connectPort”: “COM4”,
“connectBaud”: “115200”,
“connectIP”: “”,
“jogStepsize”: 100,
“jogFeedXY”: 3000,
“jogFeedZ”: 3000,
“macros”: {
“*GotoXY0”: {
“label”: “Goto XY zero”,
“gcode”: “G0 X0Y0”,
“keybinding”: “ctrl+f1”,
“_locked”: false
“*LaserOff”: {
“label”: “LASER OFF”,
“gcode”: “M5”,
“keybinding”: “ctrl+f2”,
“_locked”: false
“uiFcDrag”: {“x”: 208.18814537070574, “y”: 800.9746693079566}

Check the set up of your step motors

What type of file?

If LW display ok and your laser does not, then surely are microsteps on your firm.

@Ariel_Yahni_UniKpty SVG

@Jorge_Robles how can I find out what my microsteps are on my firmware ?
I have:

@Maxim_Matthew you need to jog and measure the traveled distance

@Ariel_Yahni_UniKpty ah… so I use the JOG control +10 or +100 and see if this is correct ?

If like me you generated the SVG through illustrator, that might be it. There was something about the SVG formatting in illustrator that messed up the DPI as I remember, gave up in the end and used inkscape.

I use illustrator and it works just fine

@Maxim_Matthew is it a home-built system? Did you calibrate your cnc after you got it working? Have you tried different file types and sources? If you jog 100mm, does it move ~83mm? If it does, it’s consistent and your settings are wrong, if not it’s your source.

@Mike_Thornbury yes its a DIY laser from laseraxe:

I used a special GRPL-Axe version to be able to use laserweb.

I testet this morning, a 100mm jog move around 83 mm.
I read the GRBL sources from @Mr_Bonce but I can’t make a big logic out of it :frowning:

where in laserweb can I adjust this gap between 83mm and 100mm ?
sorry… I’am totaly lost :frowning:

In lw there’s a console where you can enter commands. Enter $$ and you will see a configuration table. Post $100 and $101 here. Or just type $100=(the value it shows *100/83) and the same with $101. Be aware that you have bought a machine that needs some study. Take your time doing it.

@Jorge_Robles the value is 80.000, do I need to change it to 100 ?
and if yes… :-/ how can I do that ?


Type $100=100 enter And $101=100 and enter

Awesome :slight_smile:
you guys helped me so much.
all is going well now.

tank you so much helping me

@Maxim_Matthew Have a look at this:

It’s a GRBL settings calculator that allows you to model your settings.

It’s really worth getting to know GRBL, especially given the low-powered 328 controller you are using.