Help... I've got an issue calibrating a thermocouple.

Help… I’ve got an issue calibrating a thermocouple. After lots of broken thermistors we’ve just swapped over to a k-type thermocouple, using the ultimaker main board and ultimaker thermocouple sender with an AD597A chip for our extruder temp sensor.

I’ve set temp sensor to -1 in marlin firmware and I’ve removed the pull up resistor from the ultimaker board.

There is an error between actual temp and the temp reported by the software. The error is reasonably linear as you can see from the graph, using my calibrated finger, I’m sure the external sensor is correct.

The moment that the extruder is run, the reported temperature drops from 240 to 130 deg and results in the heater cartridge going to do power and the actual temperature shoots up. When I run M18 to turn off the motors, the reported temperature returns to the high value.

Something is very wrong and I’m hoping someone else has fixed this issue before.

Sounds like possibly either a trace or solder bridge on the pins from the stepper enable pins or interference ?

I’ll swap out the main board see if that kills the problem and go looking for some wayward traces. Using M17 X /Y /Z /E etc I can confirm the problem increases with the number of stepper motors enabled.

Try moving the wires from the thermistor as far away as possible from the stepper motor wires. The signal from the thermocouple is very small, and is very easily disturbed by other circuits, Especially DC circuits.

To echo what @Rien_Stouten is saying, you can actually reduce the noise by taking a drill and twisting the thermocouple wires to further reduce the noise.

Thanks @J_O11 , @Rien_Stouten @Nicolas_Duarte .

Soooo…Things I’ve tried.

  1. Swapped the ultimaker main board (and arduino and stepper drivers) for another set
  2. Swapped the ultimaker thermocouple board for another
  3. Ensured the thermocouple is isolated at the the hotend
  4. Move the thermocouple board away from any other wires (the thermocouple wire itself id shielded)
  5. Substituted for a thermistor (and swapped the pin assignment in marlin) to check everything worked.
  6. Swpped back to the thermocouple and soldering a wire directly from thermocouple board gnd to -ve power

…and still when the extruder motor is enabled the temperature reads about 100ºC lower than real life (incredible fire hazard)