Hello, I have been having trouble with chilipeppr,


I have been having trouble with chilipeppr, I seem to have a tool just wandering off and shifting a cut by several inches. This happens later on in the cut and the only thing I see that could be a problem is the buffer keeps getting low. 3-4 mostly and going yellow. Could this cause my tool to miss a command? very frustrating Is there a way to increase the rate of data flow to the tinyG? If this isn’t the problem does anyone have an Idea of why my cnc wanders off every now and then?



I know immediately what your problem is (I think) is that you need to keep all your motors powered on during any move. Your controller is probably set to let the motor turn off on an axis that doesn’t have any moves. Well, that config will cause what you’re seeing because as you move along one axis the other axis drifts. You need the motor to hold your timing belts hard into position.

My controller is set to turn off. I will change that. By the way John, this software is awesome. I’d like to thank you personally for making it. I only wish I could get the webGL thing to work on the Rasberry PI.

How should I keep the data buffer? Is there a way to increase it?

I would recommend you run CP on your laptop so you get good graphics because not having the 3D viewer does take away the coolest part of CP and then just let SPJS run on your Raspberry Pi 2. I recommend the Pi2 over the original Pi.

Thanks for the kudos btw. It’s funny, I used CP heavily this holiday weekend to mill out a bunch of aluminum and acrylic and it was really fun using my own software. It did so many things for me that I needed at every step. The jscut integration was great for me, the macros helped for whipping up quick algorithms to generate gcode, the touch plate widget was super useful, the starting of gcode from a set line (to try to save a job halfway thru), the pausing to do a tool change, the energizing of the motors to do a tool change where nothing moved on me, etc, etc. I forgot how many useful features I’ve added over the last 9 months.

@Bill_Dussault Make sure you have tinyG FW 440.14 loaded, it fixes some Power Management bugs in prior releases.

Thanks! I’ll give that a try.