Hello! I am working on a project with 2560 pixels running on Artnet over

fastled-showtell
gplus
(Stef Weicks) #1

Hello!
I am working on a project with 2560 pixels running on Artnet over Wifi with Jinx. Currently I tried it with three ESP8266, which works well the first view minutes. But than the controllers stuck for a short time and after a quarter hour, the animation comes to a standstill !? On the pictures you can see that I did a lot of effort and was also very careful when soldering. Also the signal lines are very short. I thought it can be the Wifi router. I’ve noticed that the animations run longer on WiFi-standard B than on standard N.
Does anyone know where the problem could be?

For me the easiest way would be, the whole thing would work over a ESP32. I have already inspected the library of Yves Bazin and Samguyer.
Unfortunately, I’m not that deep in programming stuff to do it all by myself.
It would be great if someone could give me some help or better a “finished” / working program code with eg 8 or 16-parallel ports for the ESP32.

(Yves BAZIN) #2

@Stef_Weicks first super job it looks nice.
Could you publish your code on github or gist so we can see what could be the issue ? Did you have a look at the serial monitor ?
How did you sync your esps ?
Rgds
Yves

(Stef Weicks) #3

Thank you @Yves_BAZIN , thats nice! But the board was only a quick build. Would be better i´d get the codes to work :slight_smile:
i tried different ones… at the arduinoforum i got this code -> https://gist.github.com/38f917090e000522f3c0604c681bac82.git
This one works fine with my ESP01 and D1 mini but with one controller i got only 4 universes (680pixel) and i need 2560pixels. So i took 5 ESP01 and tried it. But the results are the same like in the last code which i have from this project -> https://www.instructables.com/id/Artnet-LED-Pixels-With-ESP8266/
The good thing with the last code is, that i need only 3 controllers!

But controllers stuck (hold the animation on and after a few seconds they are running again) after about 2 min. and after about half an hour the animation comes to a standstill. After i unplug the controllers a few seconds and plug them in again, the animation keeps going (soft reset wonnt work).

Today i tried another Wifirouter and the results are similar. Which Wifirouter do you use and what settings…did you ever had such problems in your projects?
If the controllers are turned on and animations are running and I want to do something else in the WiFi such as surfing the internet or looking at a network hard drive, then the network is so slow that it takes forever until something happens.

The controllers got a static IP so i can exactly assign them to the respective panels (eg. with jinx). So i sync them over WiFi with my computer.

(Yves BAZIN) #4

@Stef_Weicks hello I did not make any special config on my router
may I made some suggestions on your code ?

(Stef Weicks) #5

yes of course @Yves_BAZIN !

(Yves BAZIN) #6

@Stef_Weicks could you try this https://gist.github.com/hpwit/489413b1d79daf78c6e1c923b9374e59

(Yves BAZIN) #7

@Yves_BAZIN I hope it’s compiling

(Stef Weicks) #8

thank you @Yves_BAZIN .
OK i tried it now. The colors of the universes are now different. As you can see all leds should be now red. Whether I can not say yet the controllers stuck or not.
missing/deleted image from Google+

(Yves BAZIN) #9

@Stef_Weicks hello sound like a offset declare let me check

(Yves BAZIN) #10

@Stef_Weicks try this https://gist.github.com/hpwit/489413b1d79daf78c6e1c923b9374e59
i have added a sync mechanism when some packets arrive not correctly

(Stef Weicks) #11

@Yves_BAZIN ok now it works perfect with my five controllers :slight_smile: Thank you very much! i think i have also some other things to do in my hardware, like twisting the supply cables and shielding the signal cables. Because if i start the panels sometimes the controllers wonnt connect to the network or the signals to the panels are not as good.

Do you think its possible to do more than only 4 universes on the D1 mini? Because in this project https://www.instructables.com/id/Artnet-LED-Pixels-With-ESP8266/
it works with 1360pixel on one D1 controller … but with the problems i described above…or do you think it would be better to take an ESP32 right away?

(Yves BAZIN) #12

@Stef_Weicks hello you are welcome I had the same issue with my esp32 you can go above 4 universes
look at this.


look at the read function
and

the main trick is to use a while instead of waiting for the loop function to loop 'because it’s doing other stuff and you loose universes.
let me know if I can help further

(Yves BAZIN) #13

@Stef_Weicks a nice video maybe ?

(Stef Weicks) #14

Thanx @Yves_BAZIN !! last night i tried it but didn’t get it to work …
I did a installation of the FFmpeg on my Win7 PC as they said here -> https://www.wikihow.com/Install-FFmpeg-on-Windows
but in the arduinoIDE the library already was not found … i also tried to copy avcodec.h to the program directory but its always a -> fatal error: libavcodec/avcodec.h: No such file or directory
I have the mainfolder in C:\FFmpeg including the subfolders.
Maybe you could help me with this… ?

I am also confused because of the outputpins of the universes in this code? Which one have to be connected to the lightstrips?
Isn’t it possible to get this to work with Glediator or Jinx? Because in Jinx there is also an option to load videofiles.

(Yves BAZIN) #15

@Stef_Weicks Fffmpeg is not for the arduino library. It’s a library i use do decode the videos.
to work with glediator use my arnet implementation.
I gave you the code as an example.
In your build you are using 1 esp per two 16x16 panel ? right ?

(Stef Weicks) #16

@Yves_BAZIN aah ok now i understand.
yes i´m using 1 ESP per two 16x16 panels…
so how is the easiest way to implement your artnet code to get this to work with my esp32?

(Yves BAZIN) #17

@Stef_Weicks on last question are all your universes the same size ? 128 pixels I guess

(Stef Weicks) #18

i made a setup with 3x170 and 1x 2 pixel
but if its easier i could do a setup with 128 pixel each universe

(Yves BAZIN) #19

No it’s perfect Like this

(Yves BAZIN) #20

@Stef_Weicks try this https://gist.github.com/hpwit/79cb0fcf0848466479ea4ff7a10db8a1
you will be able to push up to 31 universes
you have
#define NUM_UNIVERSES 4
#define SIZE_UNIVERSE 170 //in pixels
#define NUM_LEDS 512

this should be the correct numbers for your setup
The universes size needs to be the same for all the universes except the last one which can be whatever you need it to be

I haven’t compiled it so i hope it will work first time