Hello Everyone, I'm having lots of issues with GRBL Workspace for the past 2-3

Hello Everyone,

I’m having lots of issues with GRBL Workspace for the past 2-3 weeks, I would like to know if anyone else is having similar issues, anyone using GRBL Workspace please select one of the choices I put hereunder.

The issues I’m having are:

  • Workspace don’t load correctly when recent files are not cleared.
  • List of recent files is always empty, same issue in tinyg workspace.
  • Startup macros don’t work at all.
  • In the 3D view, the nice text that shows estimate time and travel length is no longer showing.
  • Eagle BRD import doesn’t work, if I drop .brd file it only clears current 3D view and the message of “file loaded” appears for few second, but no board is displayed in the 3D view and no GCode is generated.
  • When I check developer tools in Chrome, I see there are always errors related to three.js, see screenshot, if I clear browser data the workspace loads normally without those errors and the issues I mentioned are no longer there, however if I refresh the page or restart the browser the errors start to appear again as well as the issues.

I appreciate if anyone of you have a solution for these issues.

Ameen, all of your list of issues points to the fact that your ChiliPeppr instance never finishes loading and thus it is fundamentally broken from the start. So your list will just get longer and longer as you try to use a broken load. Now, why your load is broken isn’t clear to me. The errors you are showing in your screenshot were fixed weeks ago and nobody else is reporting those problems as far as I have seen. Is it possible you cache files and you have made it such that your cache won’t update? i.e. are you running offline? Or do you run through a proxy that won’t update old files? Have you tried Firefox?

John, I’m not running offline, no cache no proxy, I already tried Firefox and I’m getting the same errors.
I just tested CP on another laptop, I tested both Chrome and Firefox, both browsers showed the same errors and exactly same behavior. I never used CP on that laptop before.
Is it possible that my ISP is caching old files? I use same ISP in home and office so I don’t have another choice.

Baffling. Ok, anyway to show Javascript console and cut/paste entire readout to me?

I pasted the code in notepad and uploaded the file to Google drive, here is a like to the file: https://drive.google.com/file/d/0B_W4AOAuOhhwbVpkQjhfdEtsdDQ/view?usp=sharing

I noticed that in JSFIDDLE the workspace works just fine!

John, I’m checking which files are causing these issues, from developer tools of Firefox I can see that require.js and amplify.js are not modified, I’m guessing that they are cached somewhere, and from Chrome if I select “Disable Cache” from Network tab of Developer Tools, the workspace works without issues.
My conclusion is, some JavaScript files are cached somewhere outside my computer or my network, and my browsers keep getting those old files, I don’t see a solution for this issue other than visioning the workspace files.
You can see from the votes that this is not just me, other people are having the same issues.

Ok, I think I figured it out. It’s Jarret Luft’s version of the Auto-Leveller for the Grbl workspace. @Jarret_Luft can you change the requirejs.config to match the 3D viewer’s font utils, etc. Based on load order, which is random, if Jarret’s auto-level loads first everything fails.

Awesome!

Thanks gents, GRBL WS is working fine now.