Hello everyone. I have a 4 axis CNC which has 2 Y axis tables.

gplus
(Jossue Amador) #1

Hello everyone.
I have a 4 axis CNC which has 2 Y axis tables. Until the date, I used this in Gantry mode with no homing procedure and everything worked ok; however I now need to use them separately, so i decided to route one of the Y axis to the chillipeppr Y axis and the other one to the chillipeppr A axis.

When i send a G code for moving the A axis, everything works as it should. So I started the configuration for the homing procedure of all the axis. X, Y and Z axis do a correct Homing procedure. They go towards the limit, and once they reach it they backoff according to my Zero Backoff configuration, and change the Logged value for that Axis to 0.00. However, the A axis doesnt do this. It moves towards the homing limit and once it reaches it, the axis stops moving and loggs an arbitrary value on the chillipeppr screen (not 0.00 but greater than 1000) . I have disabled the max limit switch which is not connected and configured the min limit switch as 1 (used in homing). I have also setup succesfully the softlimits, and tried disabling them to see if that was the issue but the issue persists.

A curious note is that the machine is not in an alarmed state when this occurs, it lets me move any axis i want including the A axis and when i type $hom it tells me the A axis isnt home.

Any Ideas why A isnt doing the zero backoff procedure?

PD: I have tried moving the switch to the max position and changing the motor polarity to check if it was a burned input on the tiny G, but same thing happens.

(JOHN LAUER) #2

It’s possible the tinyg guys didn’t treat A the same way they did other axes in the firmware so maybe they intended different homing behavior. Have you asked them?

(carl j mcgrath) #3

If you have not already, I recommend a read of the wiki at https://github.com/synthetos/TinyG/wiki/Homing-and-Limits-Setup-and-Troubleshooting#homing-setup-and-configuration and the associated references.
It is not really clear what you have, described as as " 2 Y axis tables". Perhaps copy your parameter set, a $$ dump, to a cloud drive and provide a URL here. That will answer many questions about your setup, as seen by the firmware, anyway.
Are you generating custom Gcode for this?
Rotary mode or Radius mode ? See https://github.com/synthetos/TinyG/wiki/TinyG-Configuration-for-Firmware-Version-0.97#axis-settings
As you will see from the wiki, A axis homing is different from Linear axis homing on Z,X and Y.

(Jossue Amador) #4

Thanks for your support, I solved the issue, the relay i had the limits connected to was dead and was not closing when supposed to.

However, Im now having another issue, when homing the original Y axis with a G28.2 Y0, everything works ok and if i home it 10 times, it works ok at all times, but when homing by using the G28.2 X0 Y0 Z0 or G28.2 X0 Y0 Z0 A0, the Y axis touches the limit and continues towards the limit, this causes the motor servos to go to a positive overtravel error. This only occurs on the Y axis not on the A axis (the second Y axis).
As i stated before, if homing Y through a g28.2 y0 command, the homing procedure works ok, it touches the limit and does the zero backoff procedure, homing the axis succesfully.