Hello Can’t get ” http://chilipeppr.com/jpadie ” to load Gcode in the Gcode streamer widget.

Hello

Can’t get ”http://chilipeppr.com/jpadie” to load Gcode in the Gcode streamer widget.
When using ”Send Gcode to Workspace” button it is presented in 3D-View but not the actual Gcode in the streamer widget. It does seam to work in ”http://chilipeppr.com/grbl” anyway.

Perhaps a subscribe has changed its URL in the gcode widget.

Is it possible your localStorage has mostly filled up? I’ve heard reports of disjointed behavior when that happens. I tried to solve it with out of storage dialog boxes, but if it lands somewhere in the middle I think this can happen.

Tried “Clear Recent Files” with the same result.
If i use ”http://chilipeppr.com/gbrl” it works as advertised.
Im sadly far from being a programmer so i’m not able to debug any URL things in the widget. Thanks for all efforts helping me anyway :slight_smile:

Can you take a video of what you are doing when this issue arises please?

Apart from the autolevel widget I’m surprised to hear of a different behaviour between the jpadie and grbl workspaces for the basic sending gcode to workspace functionality.

Comparison …/gbrl vs …/jpadie



thank you. i cannot duplicate any issues using chrome or safari.

however I do not often use the button that you are pressing as I think it relates only to the registration holes. the little paper aeroplane in the top sends the main gcode from the brd import.

the main send button works fine for me in the jpadie workspace.

the registration hole creator also works fine on chrome (on my mac) and i have tested it successfully on safari for mac. both, on pressing the button in the widget, correctly load the generated code into the gcode widget and the 3d image viewer is updated.

which is logical as the eagle board widget is common to both workspaces and the changes to the gcode widget in the jpadie workspace are very minor (just adding the gcode button to spawn a window and allow copying of the raw code). so there is no reason for them to behave differently.

can you shed further light on your environment which might explain why you are seeing something untoward?

In any event, if you are using grbl 0.9x and the grbl workspace works for you, then you’re golden anyway.

I did not fund any difference between Safari and Chrome. I did find that if i disconnect from serial port (Ethernet & Raspberry JSON server) i works to publish gcode to streamer
widget. Same behaviour on both Chrome and Safari

I do not have a raspberry pi with which to try to reproduce your environment.
Does anyone else have this issue?

Tried the latest Serialport server v 1.95 and it seams that this problem is gone now. Thanks for all support . Did not mention i´m using GBRL V 1.1.

Unless someone has changed the grbl widget for the grbl workspace, that workspace does not support grbl 1.1. It won’t work.

http://chilipeppr.com/jpadie not using /gbrl workspave.

Using …/jpadie

That should be fine unless you are using inches.