Hello all! I was wondering if someone could please help me with this issue

Hello all!

I was wondering if someone could please help me with this issue I’ve been trying to fix the past month.

So I’ve built my own iteration of the prusa I3 and it works pretty well for my first build, but I have a major issue with the layer fan when printing with PLA.

Printer details:

  • Has heatbed
  • Bowden setup
  • LCD Controller
  • Layer Fan
  • Using cura 15.04.6 as slicer
  • Standard Arduino + Ramps board (not too sure about the version , but im pretty sure it’s 1.4 just based on the vendor’s website) But , I don’t know where to check for the version on the board itself though.
  • Marlin Firmware

Problem:
When I start my print with the layer fan settings enabled on cura, the first layer goes down well and the fan is not running. All good so far. But after the first layer, every time the layer fan comes on, it somehow powers the heatbed too! This results in the heat bed’s temperature going higher and higher, overshooting the set value, which is not what I want at all when printing with PLA as it starts to warp my part , especially smaller ones.
Also, when I change the fan’s speed manually via the LCD controller, it also powers the heatbed. (I’ve noticed that when I power it to like 20% , the LED on the Ramps board which indicates the heat bed being powered on , lights up faintly , and as I increase the % , it brights up accordingly.

The layer fan is connected directly to the D9 power terminal and the heat bed is connected right next to it D8 and the extruder of course is on the D10.

Things I’ve tried so far:
I’ve made sure that the D9 and D8 wires do not make contact to anything, they are well insulated from each other.
I’ve tried tinkering with the pins.h configuration file within marlin, making sure that each port is powering correctly (I’m no expert on this, but I haven’t seen anything that could explain this issue.)
Looked online through many sources but I couldn’t find anything that relates to my issue or how to get around this.

I don’t want to connect the layer fan directly to the power supply either, because as mentioned I want the slicer to manage the layer fan , instead of me manually switching it on and off.

I really don’t know what to do to fix this issue, and I would really appreciate some input from anyone who can figure this out.

Thank you for reading.

Have you checked that there’s not a short on the ramps board. If there is also check its not the arduino by disconnecting it and checking for the a short.

Keep in mind that these things are NPN switched. Meaning they share a power supply, and the ground is connected/disconnected in order to turn things on/off. If you check for continuity, you should have continuity between the positive rails,