Hello all, I am using a custom made 400*400*400 3d Printer with Vslot.Marlin with

3d-faq
3d-qa
3d-help
gplus
(Tech World) #1

Hello all,
I am using a custom made 400400400 3d Printer with Vslot.Marlin with MKS board + MKS TFT.

I am facing some issues in the prints . It is not coming properly.
Print is looking odd. It looks like skipping in X and Y.

We tried adjusting belt tension, added belt tensioner etc.We tried so mny adjustments still no success.

I tried adjusting XY jerk to 10.
Acceleration to 1000mm/s.

Coudn’t get proper results.

Please guide me…

(Daniel Scheidler) #2

drivers are adjusted? (If it really skipps steps)

for me it looks like you have wobbling on z-axis.
I’ve changed the fixed mounts between the threaded rod and the lead and use forks like this:


So the wobbling of the spinning threaded rod will not move your head on your x-axis.

(Panayiotis Savva) #3

Can you post your print settings?
Post some photos of your printer.

Are you using a heated bed?

Check that your nozzle is tight in it’s mount.

Remove the belt tensioners, they will only cause more slack, especially visible at higher print speeds.

Try printing the cube at half the speed and see if there is any difference at all.

Can you confirm the type of material, PLA?

Are you using a fan to cool down the print?

Can you confirm what drivers are on your board and if you have adjusted the reference Voltage?

Hypothesists 1: Slack due to some mechanical fault

Hypothesis 2: Thermal banding, but not very likely

Hypothesis 3: Skipping on X

(Eduardo Schoenknecht) #4

Bigger printer are more susceptible to structural issues, like bending. Doesn’t seem to be Z wobble. Put your finger on nozzle tip(when cold) and softly push and pull. Check if it moves(it shouldn’t). It can also be extrusion inconsistency, like faulty filament traction or extruder skipping steps. It is not X and Y skipping steps. Can be Z. At what speed are you printing? There is also a lot of ghosting, that increases with extruder weight, belt size, and “soft” structure.

(Tech World) #5

@Daniel_Scheidler we already tried to use some clamps at the top of the lead screw with KFL08 pillow bearing. The results are same. So, I hope it is not due to Z wobbling.

(Tech World) #6

@Panayiotis_Savva Material is PLA running with proper cooling fan.

Supply voltage 24V. Heat bed is there, but not using for PLA.

Nozzle and hot end is tight in the mount.
We tried with and without belt tensioners.

We tried to print even with 40mm/s speed.

A4988 for all axis, except Y having external TB6600. Current tried from 1.7A to 2A. Using Nema 17 Motech motor with 8kg, 2A. (We tried to use DRV8825 before also.)

Slack due to Mechanical fault - We almost tried a lot.

missing/deleted image from Google+

(Tech World) #7

@Panayiotis_Savva
missing/deleted image from Google+

(Tech World) #8

@Eduardo_Schoenknecht Hot end is tight. Extruder is Titan clone. With 437.5 steps /mm.

Speed at 50mm/s. Bowden setup.

GT2 belt 6mm for X and 9mm for Y axis.

Dual lead screw for Z axis

(Anthony Bolgar) #9

@Tech_World It is better to leave the ends of the Z rod unconstrained, clamping them in place will actually cause more of a Z wobble.

(Anthony Bolgar) #10

What size extrusion are the verticals? On my large format printer I used 20X80 V slot for the verticals so that I would not need to brace it over the large height.

(Eduardo Schoenknecht) #11

@Tech_World Your bed have a huge mass. Try to reduce Y Jerk and acceleration even more. Check if it is tight and stable. And sorry, but I believe 50mm/s is too much for it. Since you have huge mass on Y you won’t be able to have high accelerations, and that is really bad for bowdens because of the compression/pressure effect bowden tube and nozzle. You can mitigate it using adjusting linear advance on marlin. Try something like 20mm/s speed, Jerk 5 or less, acceleration 500.

(Tech World) #12

@funinthefalls We have removed the constraints already. We are using 20x40 for Z axis

(Tech World) #13

@Eduardo_Schoenknecht ok. Thanks. We will give a try for this

(Robert Rapplean) #14

This looks like the results I got when my heat sink was wobbling. Here are the details on how to look for and fix that: https://gamebetterthan.wordpress.com/2017/10/08/a-flaw-in-gregs-wades-extruder/

(Panayiotis Savva) #15

Any improvement??

(Tech World) #16

@Panayiotis_Savva @Eduardo_Schoenknecht I tried almost all the solutions. None of them worked. Finally I found there is some issue with the temperature. Temperature is fluctuation around +/- 8 deg.

If I set 220deg, it goes from 212 to 228. I tried PID Tuning several times. I changed the thermistor and heater cartridge (Original E3d V6). Updated Marlin, did PID tuning again.

I changed the board also (MKS Gen 1.4)

I am using 24V power supply. Somewhere I read that with 24V, in configuration.h, we have to reduce the PID_MAX. I reduced to 88 (from 255). Still I didnt get any result.

Now, Temperature is raising slowly. But still the fluctuation is between +/- 5 deg.

(Eduardo Schoenknecht) #17

@Tech_World Are you using a 12V heater cartridge? If yes you should use 1/4 of PID_MAX(63), as relation between voltage and power is quadratic . But this may not solve the problem, as you will have a low resolution output to your PID. I had temperature oscillation problems in the past and the cause was another. In my case I had VCC fluctuations over the micro-controller. I noticed my Rumba board had no big capacitor near the the micro-controller, and 5V Vcc oscillations were transmitted as “noise” to ADC temperature readings. A low resistance 12V heat cartrige, working with a 24V power supply can create too much noise in voltage references, and affect temperature readings. The heated BED is also important. Your bed cannot bed driven directly in a MKS Gen board. It should have an external driver, preferably an AC driver and heater.
Pay attention to your temperature readings. if the oscillation you see behaves like and sine wave it may be a PID problem, but if it oscillates randomly, with “jumps” of more than 3ºC it may electrical noise. Also check NTC sensor wiring and fixation.