Having trouble getting OTA to work,

Having trouble getting OTA to work, i set everything up but im not getting any ports showing up under ports.


OTA requires Bonjour support (or MDNS, DNS-SD stuff really). I’ve never tried to get it to work on a Windows machine but you might have to install something extra. On a Mac sometimes it doesn’t show up until I start Bonjour Browser (a small free utility).

Huh. Ive never messed with bonjour before. I have octoprint running right now which i believe uses something like bonjour. Just cant remember the name of it right now… i would just hate to have to climb a ladder and retrieve a Wemos board from the ceiling for an update lol

@Cristian_Martinez If you put something up that depends on OTA I guarantee you WILL have to go get it someday. All it takes is accidentally hitting program on the wrong sketch…it will happily write a sketch using OTA that itself does not include any OTA functions on reboot :slight_smile:

Well that was a very genius addition (not) lol. Thanx for the heads up thou!

install this on a windows machine

@Jeremy_Spencer ill give it a shot! :slight_smile:

Sometimes I have to restart the Arduino IDE and then wait a few minutes before the board shows up as a network port.

I would also recommend using a password for OTA. Not for security but to help prevent yourself from uploading the wrong code/sketch.

@Brian_Lewis tried that :confused:

Try esp8266httpupdate server with handler for example /update instead of OTA , works pretty well