Has anyone seen 5V out from HV PS dipping when laser button enabled? SOLVED using 1K POT instead of 10K

SOLVED: I have a volt meter across my Laser power POT and when I press the laser enable button the voltage setting drops 2 tenths of a volt. I’ve put a meter across the 5V(left and right side of the POT) and don’t see any change in voltage( only showing one decimal place though). When I measure from Ground( right side) to center I see a drop in voltage. When I measure from center to 5V(left side) I also see a drop when the enable button is pushed.

This tells me either 5V out of the PS is dropping slightly or the center point is being loaded.

Hmm, maybe I have to high a resistance(10K) of the POT…

SOLUTION: I installed a 1K 2W 10 turn POT. To get by with the 10K POT I’d put 2 1K ohm resistors on the POT and that stabilized the voltage. I found my original and saw it was a 1K… Then while searching these forums I saw 5K and 10K mentioned and probably why I put in a new 10K. So get close to a 1K POT and 10K is just too high.

POT hack
L--------C--------R
/—1k—|—1k—\

Something not right here.

I don’t see any connection between the enable button (P) and the pot, which provides a reference for the amp that controls the LPS’ PWM?

The pot wiper is connected to a high impedance input so it should not draw any appreciable current.

The pot is across 5V so:
I = E/R

1K pot: 5/1000 = .005 Amps = 5ma
10K pot: 5/10000 = .0005 = .5 ma

At these values, the pot doesn’t load the 5V supply?

There is no direct relationship between the pot and the enable switch?

Perhaps there is something weird with the optocoupler.

1 Like

I don’t have the schematic for the HVPS so was just operating on observation. IE I was having issues with my machine not burning properly and noticed my voltage meter on the POT dipping when I enabled the laser and it was dropping from 2.6V to ~2.4V. So I’d researched POTs and saw mention of a 10K POT and still my problems persisted.

I finally got after it again last night and looked at my 1K pot I’d pulled and it was reading 3.4K, then I found many posts on using 10K, 5K and 1K POTS. When I set 2.6V and measured the POT center to high and center to low it was close enough to 5K on both sides I got the idea of putting 500 ohm resistors from center to High and center to low to get me ~1K POT. It’s very solid now. If I adjust the POT to just when it turns 2.7V and I press the Enable button it can jump down to 2.6V but a small adjustment beyond the edge of 2.6/2.7 and it will stay on 2.7V.

What does the circuit look like which senses the wiper of the POT?

And there could be a failure of the HVPS waiting to happen. But I have removed loading of the 24V by using an external 24V 5A PS for the powering of the MKS Sbase v1.3 board and stepper motors.

The schematic is above.

The behavior you are describing is not normal.

Ok, I’m catching on. P is the Enable button signal and IN is the POT wiper. Looks like they are connected via that OpAmp. IIRC, op amps want their inputs to be the same so a change on P which grounds one side of the opto couple diode and energizes the base of the opto coupler transistor effectively putting ground on the voltage divider and changing the voltage on pin 1 of the OpAmp and that’d change the voltage on pin 2 of the opAmp and change the circuit connected to the wiper of the POT. 500 ohms to ground and/or 5V is going to more heavily influence 5,000 ohms to gnd or 5V in a circuit with those 2 15,000 ohm feedback circuit around the OpAmp.

What i know for sure is that right now, with the 470 ohm resistors across the 10K POT it is close to factory and working more like it used to work before the original 1K 2W POT resistance went up to 3.8K(just measured it).

the important thing regarding power control is what voltage is on IN…
When you adjust the pot it should go from 0-5V.

I don’t see how a pot connected properly to 5v and ground would any way to behave any differently.

correct and it should not be loading down or changing. IIRC there is 5.4V on the 5V pin relative to gnd and I did not see any movement of it when the Enable button was pushed. BUT, if I measured from ground to the wiper/IN then I would see the voltage change slightly when Enable button was pressed. Same goes for if I measured from the wiper to 5V, it too would fluxuate slightly when the Enable button was pressed.

I had only measured from gnd to wiper and when I saw the fluxuations I thought there might be a grounding issue and I rechecked grounds on both 24VPS and HVPS and MKS Sbase. Then it dawned on my the POT was only connected with/to the HVPS so nothing should influence that wiper voltage but the HVPS.

Maybe the opto-coupler is aging or maybe one of the caps in the circuit is aging and influences the 10K POT wiper voltage more than a new HVPS would.

I’m going to wait until it’s night time when things get colder and a little more dampness in the air and see if the K40 still operates more consistently with this ~1K POT setup.

Try:
Disconnect the pot from IN
Read the wiper to grnd or 5V and see if the voltage still changes when the enable pressed.

I can try that but I had watched the 5V and it was not changing with the Enable button.

BTW, if something was inducing an equivilent of a 40K impedance to ground on IN it would drop a 2.5V wiper(50% point) to 2.4V as the circuit of the wiper to ground would be a parallel circuit with 5K of the POT and 40K resulting in ~4.4K ohm. But, with a 1K POT, in center position of 500 ohms up and down to ground, that 40K impedance results in a 494 ohm equivalent resistance from the wiper to ground. FAR less than when there was 5,000 ohms to ground.

Maybe the 5V is getting noisy now that there’s little to no load on it without the M2Nano or nothing on the 24V of the HVPS. noise on the opto-coupler would cause noise on the other side of the opAmp and that would/could induce current in the capacitors to ground which would influence the load on the connection to the wiper and influence the wiper voltage stability.

Let me put an O’scope on it.

I saw no drop or effect on the 5V but on the wiper there was still a very slight drop in voltage and a slight increase in noise on the signal. No added noise was seen on the 5V line.

Video link K40 10K POT noise - YouTube

@donkjr the new POT failed… All I did was make a cut to test things, did a few adjustments on the POT to verify the current meter was showing expected currents and then it just stuck to 2.4V and no movement of the POT effected the PWM voltage. I disconnected the POT and removed the 470 ohm resistors and the POT measures 10K across it but nothing on the wiper from either end.

I put in another new POT, no 470 ohm resistors and sure enough, same as previously I see ~2-3 tenths of a volt drop when I enable the laser. This is a rather small POT so no where near being a 2W POT like the original. I will be finding a 1K 2W POT and installing it for further testing of this issue.

I will also pull the wiper wire and do a current measurement on it to see what kind of current is being drawn on the POT.

The 2W rating seems to be over kill as 5V/1k is only 5mA and 5V * .005 is only 25 mW

And I measured current on the wiper to be less than 1mA…

There is a fluxuation of the current on my HVPS between laser on/off switch position.
A swing of .12mA :
.05mA to -.07mA between laser disabled and laser enabled switch position.

That wattage is the only panel mount pot available in that size, not unusual.

Thats what I expected as it is connected to a high impedance input.

I am not sure why it fluctuates but that is very small so why are we concerned about it.

it is small at the wiper but it causes a 2-3 tenths of a volt drop in the voltage on IN when P is pulled low and that effects the total power setting. I can compensate by setting the voltage to 2.9V so it ends up at 2.6V when ready to cut/etch but I was trying to find the cause.

I put a 1K 2W 10 turn POT on and the displayed voltage( as seen on IN input to LPS ) is far more stable than with 10K POT.

It now only raises or drops .1V if on the upper or lower end of a voltage setting. It is easy to find the middle of the band where the voltage is stable. Finally setting at 2.4V which is 18mA on my machine and I never run at 100% so only when using the manual pulse button with the tube see 18ma.

Good to know thanks.