Has anyone had success with Photons recently?

fastled-support
gplus
(Peter Buelow) #1

Has anyone had success with Photons recently? I have code that used to work (a while ago, maybe 18 months?), but with the 3.1.5 and 3.1.8 available in the libraries of their web build tool, I can’t get anything to work. The simple blynk app just works weird, no matter the state of the allow interrupts hacks. I either get timing that doesn’t make sense (no code change other than the pin #) but the colors are right, or the colors are wrong, and the timing still doesn’t make sense. I think it’s pretty clearly an interrupt issue, but like I said, the ALLOW… hacks don’t change the behavior.

Adafruit Neopixel code works fine on the same setup…

I don’t want to write all new code if I can avoid it. Just wondering if there is something special I can do to fix this. Swapping the micros would be complicated as I have a bunch of boards purpose built for this stuff, so I’m hoping I can fix this as is.

Thanks.

(Daniel Garcia) #2

The sparkcore/photon code has gotten a bit stale - the last time I dealt with it, their library manager meant that I had to maintain a separate repo and change some of the layout of the library - so keeping it in sync with the main library was always a pain.

(Dougal Campbell) #3

@Daniel_Garcia I think they re-did their library layout since then (well, I know they changed it at some point). It might be worth a few minutes to re-check and see if the current Particle library setup is friendlier to integration?

(Daniel Garcia) #4

When I start actively doing library work again it’s on the list - but it’s a long list at this point.

(Peter Buelow) #5

I’ve been digging, and the only valid FastLED version is yours at 3.1.5 using the old spark.json file. That version does not work anymore, or may never have (or I’m dumb, that’s not really out of the question). I didn’t use their build tools for a long time, preferring to checkout their github firmware and build everything that way. I could include libraries uniquely in that case, which is pry why mine worked as I could pull it in without their rules. I can’t do that anymore for a variety of reasons.

I’ve grabbed a fork that worked for me based on 3.1.4, and uploaded it privately using those changes + the new library format. It builds, but I’m not somewhere I can test until later.

I’ll update here later tonight when I get a chance to test it.

(Ryan Cush) #6

@Peter_Buelow I’m using FastLED 3.1.5 on Photon and it works well. I’ve encountered some issues w.r.t timing/interrupts on certain animations, but otherwise it has worked fine. Note that you need #pragma SPARK_NO_PREPROCESSOR at the top of your file (which also requires you to use prototypes for all of your methods.)

(Peter Buelow) #7

Thanks @Ryan_Cush , I’ll try that. I wasn’t using that, and it wasn’t working at all. But, that might help me out. I’ll test it later. I did get FastLED working today downgrading to 0.5.5 firmware version, and building it manually with a custom FastLED. This would be significantly easier.

EDIT: Yeah, that worked. Thank you. This is so much easier to use.