Guys , will someone please tell me way whenever i try to update my

Guys , will someone please tell me way whenever i try to update my firmware update it never works . i just got this board back it says that it has 440.14 in it and i go to chilipeppr and try to us it , it then tells me that I need to update the firmware , So i then download file and try to update it it will not connect . PLEASE SOMEONE TELL ME WHAT THE $UCK I AM DOING WRONG.

What method are you using to update the firmware? Avrdude from command line? Synthetos’s updater? Or the new firmware updater built into ChiliPeppr? Also, what version of firmware did you download? Screenshots help too.

i have been trying to use the Synthetos updater , this is the only way i know how.

If you run SPJS ver 1.83, try the new FW updater included there.
Or, if you are a Windows user, you can try this method :

How do I get the most SPJS , when I try to update through chili peppr it tells me I need to update SPJS

@Kurt_Schuppert I assume you are looking for the most recent SPJS? Look here:

ok, I got SPJS 1.83 and i am connected , when i go to the programming tab and pick the file 440.18 and tell it to program it tells me download 100% and the programming says 100% under the progress .

Serial port busy

can you tell me what this means ?

Yeah, it means you are still connected to your device in the main workspace and so the port is locked from being able to be programmed. Disconnect then retry.

john , i did a compleate reset and this is what came back now
Could not find board: arduino:avr:tinyg


Do i need to reset set the board before i hit program?

@Kurt_Schuppert Kurt, wait for John’s guidance, I don’t have hands on experience as I am on holiday away from my tinyG.

I believe the answer to your question is no, you do not need to reset, the programmer will send a reset command to tinyG to put it into bootloader mode.

But you do need to disconnect SPJS from the serial port before initiating the programmer process.

so i first need to connect and get chilipeppr working and talking , then open the programming and then kill the SPJS and hit the programming and see if it will program then ?

@Kurt_Schuppert I don’t believe you want to kill the SPJS (as in terminate), because it hosts the programmer as a sub-process. I believe you get connected and working, then click the disconnect button in the Serial console widget

If you reset the board, it probably came back as a different port and you didn’t hit refresh to see the new port so you’re trying to program to a non-existent port. On Windows devices come back as the same port so what OS are you on and when you said reset, what did you reset since folks seem confused here.

I had a very similar error recently. I’m also using Windows, and when I tried using the Syntheos TG Updater, I kept getting an “undefined” error (that was part of a longer error message.) I ran the updater from a command prompt and got a bit more detail from the error message… apparently it can download either the latest stable or edge firmware, and the edge firmware was failing when it inspected it to determine the version. So it looked for a version tag in some json metadata, but the version was “undefined” and I got that error at the top of the updater in the updater UI. I had to run the manual update process from the command line as descibed here, and I had to use the -e switch too.

I’m wondering if he’s having the same issue.

Guys , I will be honest with you I am starting to get tired of trying to keep up with getting the updates to work just to keep this thing going , I have spent more time on working with the updates then I have cutting. This is not fun anymore. I would think that a software company would want this to be as simple as possible so they could sale a lot of these things , but when you are not a programmer it just makes it very difficult to learn . I am all up for learning but when I bought it I thought that I could get it setup and that would be the majority of what I would have to do . I am just trying to make and cut some stuff, not try to learn how to become a programmer . I am going to make a video tonight to show you how that I am doing it and maybe you will see something that I am doing wrong.

Here is a video of what i am doing when i am trying to program in chilipeppr , please let me know what i need to do to get this completed . iIn the video i say 1.80 but i am using 1.83

Ok, it’s because when you downloaded Serial Port JSON Server you didn’t actually extract the zip file to your local hard drive and then run spjs. Instead, you ran the exe from inside the zip file when you opened the zip file and what that does is it doesn’t extract anything other than that .exe file. That’s a big problem, because that Arduino folder in the zip file is key to making all of this work and you never extracted it. I’ve never seen anyone do it the way you’re doing so I never thought anyone would. Are you possibly re-downloading spjs every time you use ChiliPeppr? Just not sure why you would be running spjs the way you did in the video.

can you tell me how i should be going it , so i can correct it ?

Well to extract the folder, just open your zip file in Windows Explorer, and then click “Extract all”, and make sure “Show extracted files when completed” is checked. Then click “Extract” and when it’s done a new folder will open, then you can run it from there, which should be something like "My Computer > Downloads > serial-port-json-server_windows_386 (notice how “.zip” won’t be in that path at the top of the window)