gShield v5 + Due: Chilipeppr Comm Error Hey,

gShield v5 + Due: Chilipeppr Comm Error

Hey, i am really struggeling with Chilipeppr now.
It worked a week ago but now there seem to be an Update and now it is Not working.

Windows 10 (same behaviour on Ubuntu 16.10)
g2core Edge latest, now 87 stable

I can Connect to Board through putty and Controller and run everything… Works like a charm.

But with SPJS and Chilipeppr it doesnt work. Seems to send to Board but not gets answer…

SPJS 1.92 working, connecting and showing both serial Ports.
SPJS Shows up in Chilipeppr ( Chrome)
Can Connect
TinyGv2 Shows up on Port 11 and 12
Sometimes Connect Works sometimes Not.
When Connected, you See Chilipeppr sends commands to board. But don’t get the Status Back. Even a Manual $ doesn’t get a Response.

In the SPJS Widget in Chilipeppr it shows me 2 queued commands.
when i enter $ into command widget it just says {“ej”:""}. And queue shows 4

When killing SPJS and reconnecting with putty Board Works without restart.

Any help is appreciated. working on it almost half a Day already. :wink:


What init commands are you sending to the TinyGv2 because the init commands chilipeppr sends to v8 boards is solid, but historically I’ve seen those init cmds crash v2 boards because they did not support them the same way. That’s why I created the “Send No Init Cmds” option of the TinyG workspace. Look in the upper right corner triangle pulldown menu in the TinyG widget to reload ?v9=true for workspace.

sigh boom it works now…
you are faboulous John!

Do you think it might be useful to add it to g2core wiki?
Because it literally cost me hours trying to debug it on my own :wink:

Adding ?v9=true is a must for gShield v2, I’ve spent hours on that long ago and posted on G+. The time spent is just a ‘learning curve’ that everyone has to face on the way to success. Keep on going.

Well, the last build I used for TinyGv2 the init commands worked fine that the v8 uses, so I didn’t have to do ?v9=true. So, honestly, I’m not sure why different firmware versions from the Synthetos guys work or don’t work depending on their build number. Could you ask them to always test that in their regression testing? Because those init commands are pretty important for ChiliPeppr to work correctly. They put it in the correct JSON mode. They ask for all the position reports so your Axes widget works correctly. Etc.