GRBLGRU stop working

Good morning after changing video card Grblgru has stopped working. Even returning to the old card and uninstalling the drivers of the new one, the program no longer opens. Win7 operating system. I attempted a system restore with no results. before formatting the pc i need some suggestions. Your program is truly fantastic!
Adriano

Sorry for the late reaction.
So far I only had a problem with the graphical display once. This was simply due to the resolution. Otherwise I don’t know of any other problems in this area.
Please check your screen resolution. If all other programs work correctly it must be GrblGru. In this case install the current beta version V3.49.20. Please let me know if the error persists.

2 Likes

Thanks for the feedback I will try and let you know soon
Best regards Adriano

Hi I tried to uninstall the old version and install the 3.49.20 without results by changing various video resolutions and running it as an administrator. A dos window appears for two seconds and the program does not open. Before the installation of the new card everything was working perfectly.I have now uninstalled the new card but got no results. Before formatting the pc I wait for your answer. Thanks Adriano

Once again, sorry for the late response. I did not get a notification that you had posted.
I think I did something wrong with my notification settings.

But now to the actual problem. I don’t think you need to reformat your PC if your other programs are working.
Try a similar program. E.g. a free CAD program.

Thanks for the reply. GRBLGRU worked really well and I’m sorry to switch to another software. Sin. I’ll try to learn how to use some other CAM. Warm regards Adriano

Adriano, can you please answer me again 2 questions ?

  1. Is it correct that all other programs run without errors ? Only GrblGru is not working ?

  2. What resolution are you using now ?

I will do tests again on a Win7 system with your resolution. I will inform you here if I find something.

Thank you for your interest in my problem. All other programs like Aspire, gcodesender work perfectly.
The problem started after I installed the GForce video card. Now the system has been restored and the card deleted by uninstalling the Gforce drivers as well. The screen resolution is 1366x768. I have tried various resolutions without resolving. There must be some conflict but I don’t know how to resolve it myself. The program worked perfectly before and I miss it. Thanks for your availability … See you soon

Good night again a clue, I tried to install Blender and it doesn’t work. The message that appears on the screen is "Failed to set 48000 Hz got 44100. It needs openGL 3.3. Which OPENGL does GRBLGRU need. Confident look. Thanks

I checked it again yesterday. On a Win7 computer with the resolution 1366x768 GrblGru runs without errors.
I use the OpenGL version that is part of the Windows operating system. That can’t be the problem. The only external component that GrblGru needs is the .Net Framework V.0, which is also usually installed with the system.

Let’s try following again:
Please download the new release version V3.50 again. Delete the two directories:

  • C:\Program Files (x86)\toe\GrblGru
  • C:\ProgramData\GrblGru

Then run the setup.
Then start the GrblGru shortcut by holding the SHIFT key !
GrblGru will start in test mode. A series of windows (See pics below) will appear where you always have to press return to continue. It is best to take screenshots of everything that is displayed.

pic 1

I followed your instructions step by step but holding down the shift key and double clicking on the Grbl 3.5 icon nothing happens.Where am i wrong? Any ideas … thanks for your patience …

And what happens if you start GrblGru without Shift ?

Nothing happens … if I run it as an administrator, a dos (command) window appears for only a few seconds.