GRBL-LPC on Smoothieboard "No supported firmware" problem

gplus
(Knut Gunnarson Veum) #1

Hi

I have uploaded GRBL-LPC to a Smoothieboard and try to connect it to the latest version of LaserWeb4 on my computer running with Windows 8.1. When I connect to the board I get the message “Machine connected” but after about 10 second I receive the message “No supported firmware detected. Closing port COM3”. I have tried to save the .env file to the installation folder, also with “GRBL_WAIT_TIME=5” included in the text file (with several values for the wait-command). I included the LOG_LEVEL=3 command in the text file and it wrote a logfile in the installation folder.

Unfortunately, nothing worked. I’ll really appreciate any help solving this issue.

0 Likes

(Joseph Alexander) #2

unplug the usb cable then try again, sometimes that works.

0 Likes

(Knut Gunnarson Veum) #3

@Domm434 Thanks for the suggestion, but it doesn’t work in my case.

0 Likes

(Claudio Prezzi) #4

Are you sure COM3 is the right port and that grbl-LPC was flashed correctly?

0 Likes

(Knut Gunnarson Veum) #5

@cprezzi
When I installed the driver from VCOM_lib/usbser.inf it was COM3 that was used. I am not sure this is the right one, but I tried to change it at device manager and it did not work with other COM-ports either (I did not try everyone else though).

I saved the latest “smoothie_firmware.bin” file from <https://github.com/cprezzi/grbl-LPC/releases> to an empty SD-card and renamed it “firmware.bin”. After the reboot I removed the SD-card from the smoothieboard and used a SD-card reader (just to look at its contents) and there is no .bin file on the SD-card anymore, only a file named “FIRMWARE” with capital letters. I believe that this mean the .bin file have been recognized by the bootloader, but I am not sure it is flashed correctly.
Is this the right procedure, or did I do something wrong?

PS. I also tried to use older releases of the smoothie_firmware.bin the same way, but unfortunately with the same result.

0 Likes

(Claudio Prezzi) #6

Your procedure to flash the firmware and the rename of the firmware.bin file is correct.

The “No supported firmware” message you get means that LaserWeb doesn’t get the welcome string “Grbl v1.1f” from the firmware within 10s after serial connection. Usually grbl-LPC sends that less than a second after each connect.

Try to add the line “RESET_ON_CONNECT=1” to the .env file. This will cause LW4 to reset the board right after connection, which forces the welcome message.

0 Likes

(Knut Gunnarson Veum) #7

In the .env file I saved to the installation folder, RESET_ON_CONNECT=1 was already written. I saved the .env file from this website: https://laserweb.yurl.ch/documentation/initial-configuration/65-grbl-lpc-1-1e and used the “.” before “env” in the name with nothing in front. I also tried to use a computer with Windows 10, with the same result.
Can I somehow monitor the process, so I can see if the firmware is sending the welcome string?

0 Likes

(Knut Gunnarson Veum) #8

Also, the version of LaserWeb I installed, where downloaded from this page https://github.com/LaserWeb/LaserWeb4-Binaries/releases. I use the latest release, named “LaserWeb.Setup.4.0.996-134.exe”.
Is this the right version to use for my application?

0 Likes

(Claudio Prezzi) #9

I think you did everything correct, also the correct LW version.

To check if the firmware is acting correctly, you could connect the serial port with a terminal program (or the serial term of the Arduino IDE) instead of LW. Connect the serial port and then reset the board. You should see the welcome message “Grbl 1.1f [’$’ for help]” and you should get the config after you send $$.
If that is not the case, then the problem is in the board/firmware. Otherwise it’s on LW side.

0 Likes

(Claudio Prezzi) #10

There could also be a problem with the “.env” file not beeing used. The default configuration in Win10 is hiding file endings like .exe, .doc in the file explorer and prohibits you from naming a file “.env” olny.
My advise is to create the file as “env.txt” first and then use a command line command like “ren env.txt .env” to rename it.

0 Likes

(Knut Gunnarson Veum) #11

I created the .env file, by following the instruction from Sam Bakker in the end of his tread from 10/7-2017 where he had about the same issue. The new file looks just like the one I saved from the internet, and it does not solve the problem. When I write LOG_LEVEL=3 in this file as well, it created a logfile in the installation folder when LW is opened. Would this happen even if the file was not to be used? I tried to use putty as terminal program, but I did not see any welcome string.
Could there be something wrong with the drivers I installed?

0 Likes

(Claudio Prezzi) #12

@Knut_Gunnarson_Veum You are right. If the log level switch works, your .env must be ok.

0 Likes

(Claudio Prezzi) #13

If you don’t see the welcome string from putty, you can still check if the board is reacting. If you send $$ you should get the whole list of config values. If that doesn’t happen, it must be a problem with the firmware. Try to flash it again or flash back smoothieware to see if it works.

0 Likes

(Claudio Prezzi) #14

Just to be sure: You have an original Smoothieboard, not some clone, right?

0 Likes

(Knut Gunnarson Veum) #15

Yes, I ordered the Smoothieboard from Robot Seed. This is the board I have: http://robotseed.com/index.php?id_product=101&controller=product&id_lang=2. I use external drivers, therefor I ordered the 0X version. Just to be sure, is it the EN1, DIR1 and ST1 that is used for the X-axis and EN2, DIR2 and ST2 for the Y-axis?
I have removed the smoothieboard from the laser cutter and tried using Putty with several baud rates, but could not receive or send any commands or information. I also tried to use smoothieboard’s independent serial (UART) port, with a serial to USB adapter, like it is described here: http://smoothieware.org/uart, but the result where the same.
When I uploaded Smoothieware to the SD-card, I received the message:
Smoothie
ok
At this point, I could also send commands to the board, and the LED nr.1, 4 and “3.3V” on the board where constantly on, while LED nr. 2 and 3 where flashing. When I uploaded GRBL-LPC firmware, the only LED that was on, where the one labeled “3.3V”. (during the hole period, the only power supply I used, where my computer through the USB-cable. I tried to use different USB-cables)
I concluded that something must go wrong when I flash the program. I believe that the bootloader recognizes the firmware.bin file, because also this time the .bin file where renamed when I looked at it, but I absolutely do not know what causing this flashing-issue. Do you have any recommendation for how I should proceed the troubleshooting?

0 Likes

(Knut Gunnarson Veum) #16

@cprezzi I am very grateful for the help I have received so far, but it is possible to get answers on how to continue the troubleshooting?

0 Likes

(Claudio Prezzi) #17

Ok, that means you have to solve the board/firmware problem before trying with LW.
Are you sure you downloaded smoothie_firmware.bin from https://github.com/cprezzi/grbl-LPC/releases? Usually I would suggest the newest one, but you can also try older versions.
https://github.com/cprezzi/grbl-LPC/releases

0 Likes

(Knut Gunnarson Veum) #18

Now I have tried to save all the precompiled releases of “smoothie_firmware.bin” as “firmware.bin” at my SD-card (one at the time) and none of them worked with LW or PUTTY. I find out that when I opened putty for the first time after flashing a new firmware, I received an “error: 7” message and a list of all $-parameters, but I could not write anything. This happened with every firmware I flashed, no matter if I used 9600 or 115200 baud rates, but only the first time I opened PUTTY after flashing. When I closed PUTTY and tried to open it again, I could neither read or write anything.
What is this “error: 7” message?

0 Likes

(Claudio Prezzi) #19

According to https://github.com/gnea/grbl/wiki/Grbl-v1.1-Interface the err:7 means “EEPROM read failed. Reset and restored to default values.”

0 Likes

(Claudio Prezzi) #20

I would tell you to try it with another smoothieboard, but I know they are not cheap and you probably don’t have a second one.

What you could try is to connect a power supply to the board (additional to USB) for flashing and testing.

0 Likes