Good evening ChiliPeppr community,

Good evening ChiliPeppr community,

I was hoping to get some input on using a raspberry pi3 with my TinyG v8 and ChiliPeppr.

I have tried connecting to the TinyG both using Ubuntu 16.04 and Raspian Lite. I initially thought that the Rpi3 had the FTDI VCP USB drivers but am not sure.
Do I need to install them or the D2xx drivers? I’ve read that both can not operate at the same time. I have also not been able to get CoolTerm to correctly execute in either program. When I try to run it, it never loads. In ChiliPeppr it also says that the TTY0 port can not be accessed. I have tried giving coolterm permission as well as the JSON (1.88 &1.94) servers permission though the Properties tab. That did work so I tried giving them permission through the command line but got lost in a bunch of errors; I am new to Linux.

P.S. I have successfully controlled the TinyG from regular Windows laptop.

On rpi3 I’ve just plugged in the USB and the tinyg shows up immediately as serial port. Then I download and run spjs and I’m good to go

hey there. i used this guide to set up rpi3 with tinyg.
good luck :slight_smile:

@Reece_Maganzini Restart your computer then try starting JSON from terminal window. Execute a sudo command first to give full permission. Also you can use a -v to see what JSON is doing in the terminal window. You will have to navigate to the directory where your executable JSON server is through terminal window. There’s a post here a few weeks ago where other’s helped me. Good Luck!

Thanks for the help everyone. Apparently my Rpi3 likes that the TinyG is already plugged in before I power it on.

I also found that my TinyG shows up as ttyUSB0 where as on some others it shows up as ttyACM0