Glowforce svg to K40

Hi guys,
I have a K40 laser engraver and have purchased an svg file which I’m guessing is for a glowforge.
I have changed the colours of the file (red for cutting, black for engraving) as is required for the K40 in inkscape, however when I open the file in K40 whisperer (which I use for my projects) the file is all red, however it is saved in red and black in inkscape. (I want the cut and engrave like the first gingerbread man)
Any help on how to fix this. I’ve added the file for assistance.


There might be extremely thin red lines.

If you got Inkscape 1.0+, use View → Display Mode → Visible Hairlines.

Once I have the design created in Inkscape I will often setup the laser details in Lightburn after the fact once the SVG is imported. ie set grouping, setup layers and preferences for laser operations. I then keep both the Inkscape and the lbrn2 files if for some reason I come back to the design and want to change things.

Thanks guys.
I’ve not used lightburn before I’ll have to check that out. And also the update of inkscape when I get home from work

Sorry, I’d thought you said Lightburn but indeed said "K40 whisperer "

But I think the same process can apply as you become more familiar with the tools and how they interact.
Sometimes things like grouping can cause problems when saving and then importing Inkscape SVG files.

When I selected the visible hair lines, nothing happened on the screen!

instead of trying to click on the thin line, have you tried selecting via bounding box?

Hi Doug,
I’m not sure what a binding box is.
I’ve highlighted areas, individually selected etc.
In inkscape it’s all the correct colours, however when I open in K40 whisperer it’s the opposite.

oops, will fix it as I intended to post “bounding box” and not “binding box”.

ok, I tried to create 3 lines of colors Red, black and Blue then saved the SVG file and opened in K40_Whisperer and got all 3 lines as black. Hmm, I used to be able to do this as I used to use K40 Whisperer…

I will have to go back to Scorches HowTo files and see what I’m missing because in Inkscape I set the Fill to the RGB color value, no Stroke color(will look at this) and set the line width to .1, .2, .1mm

SOLVED: You need to set both the fill and stroke values to the RGB values.

1 Like

yep did that already

does this not show up as 3 colored lines in your K40 Whisperer?


right now it would appear that i cant open anything in K40.
I greatly appreciate all of your help

if you right-clicked on the SVG image I posted and saved it then K40 Whisperer will not import it then it’s likely K40 Whisperer isn’t configured or finding Inkscape. Check the general settings in K40 Whisperer where it specifies where Inkscape executable is.

Open the file with a text editor and remove the <style>....</style> section at the beginning.

Inkscape seems to ignore it while K40 Whisperer doesn’t.

Once you’ve removed that section, the SVG will behave as usual.

You may need to upgrade K40 Whisperer. There were some Inkscape 1.0 compatibility issues with older versions.