Genmitsu CNC Router Machine PROVerXL 4030

I am looking for some help. I just got this machine. The box was pretty much torn up, which doesn’t surprise me. When I received it, it was used. I paid full price for it. So, there’s that. I’m on a deadline, so I decided to go ahead and put the machine together. I’m using the DeWalt DW611P for the spindle with the adapter that was included with the CNC. I’m using VCarve Aspire to create my pieces. I’m saving my tool paths using the GRBL(mm) post processor. And I’m using UGS to run the cuts. But I’ve also tried VCarve’s VTransfer. And I’ve also tried Candle. The machine is doing all sorts of random things. I’m running a test cut and in UGS, I’ll start the trace for the outline of the piece. It will start, and get about halfway through, then it stops with an error along the lines of not being connected to the controller. It will go into “Hold”. I will hit Start and it will resume and finish the trace.
Then if I start the cut, it will start and run for a bit, then it will stop. Or, it will run, and then the spindle will start cutting in a straight line beyond the model on either the X or Y axis until it hits the limit switch. I’m setting zero to the center of my work surface and using the probe.
The controller is using GRBL 1.1h.
I’m at am impasse here and it’s driving me crazy.

it sounds like a controller and/or USB connection issue and I would be monitoring the Console output to see if you see output from the controller like it rebooted( ie GRBL version echoed to the console ). There should also be some error code spit out if there was a buffer error like USB problems.

If the controller has the ability to store the toolpath/gcode and run in stand-alone mode that’s a good way to eliminate if it is the USB bus. We’ve seen machines have issues with things like weak USB cables(really thin wiring, no filtering, etc) and things like current loops where the PC and CNC are on different electrical phases and one phase and grounding is poor. Then there’s knowing if there’s a motor on either electrical phase being used which could glitch noise into the system. Compressors, washing machines, HVAC, etc all have motors which are big enough to send lots of noise into the system and load a line on startup.

Also try testing with no loading of your X and Y motors and spindle by running a few inches in the air and see if you still get issues.


Thank you for taking the time to respond. I checked the USB cable, and I realized that I used my long USB-A to USB-C cable that I bought for my iPad. It doesn’t have ferrite rings on it. So I got a long USB-A to USB-B with ferrite shields, and it’s working fine now. I’m super relieved. Thank you again for the suggestions. I appreciate it.