Genmitsu 4030 cutting smaller than expected

Hi, just brought the machine, and tried it out. Tried Easel and Aspire when I import these into Grblcontrol one of 2 things happen: Aspire image looks ok in GRBLControl but when it comes to machineing the design makes the image rediculously small to the point you cannot see anything other than a hole, or secondly plunges the bit into the wood and breaks the bit. Easel manages to get the right size of image when imported in GRBLControl ,starts and plunges into the wood breaking the bit.

I would be most grateful if someone can help me figure out what I am doing wrong? the size of the images I set to 2inches and the thickness of the wood 1/4 inch and a maximum cut depth of 0.02 creately appreciate any helpful advice.

The default units for GRBL are mm not inches — is there any chance that what it is doing is exactly 25.4 times smaller than you expect?

Sounds sensible but just did a little experiment I raised the bit up about 2 inches, and zeroed it. When ran it drew a square in the air which looked fine. Then I moved it back down to the wood and zeroed it again, and it drew a minature again. Something very strange, I know it must be something I am doing but what you said sounds right I did check the settings though and it said inches. Do you know if there is a simple test I can do that has the measurements documented? then I could see if its me or the machine?

Paste sample gcode here, or at least the first few dozen lines. You can format then to make them easy to read by putting them between lines with just ``` on them, like this:

your gcode here

(Those are single back quotes, as in the key to the left of the 1.)

I tried putting more in but it would not take it.


If those layers are representative, they are relatively small even in inches, just a few hundredths of an inch total movement.

I’d explicitly put a G20 at the top of the file if you want it in inches, in any case.

Are you talking about $13? If so, that’s just what it reports, it doesn’t change the default units to be G20 (imperial) instead of G21 (metric)

Or is this not a GRBL control board? You might want to post more details about what firmware is running on the system you have.

Thank you for taking the time to help, the line you showed displays as you said, I have written the default setting from the GrblConsole which is what I get when I run the app, can you see if there are any mistakes they are the defaults it comes with please, I did notice the G21 appear as you mentioned meaning MM but not sure then what the Units means is the settings screen?

Status Query Period = 30
Units = inch
Rapid speed = 2500
Acceleration = 100
Spindle spee min = 0 max = 10000
Probe commands = G21G91G38.2Z-30F100; G0Z1; G38.2Z-2F10
Safe Position Commands = G21G90; G53G0Z0

Port = COM4
Baud = 115200

Could not find any info on setting the 8-bits, no parity, and 1-stop bit in the menu. But I will change the G21 to G20 and let you know.

Is this the tool you are using?

Type $$ in the Console box of whatever software you are using and paste the results here,

I’d strongly suggest having your CAM create its output in metric, regardless of the units you use for design. I don’t think there is any way to configure grbl to have imperial units by default, except for what it sends back in its reports of where it is. You must have a literal G20 in your gcode file before any movement commands if you want your gcode to be in inches. But then you’ll need to look at the gcode and see if it makes sense in inches!

If you have confusion between inches and metric somewhere in your workflow, you’ll end up off by a factor of 25.4 because there are (by definition) 25.4 mm per inch.

1 Like

Many thanks Michael for your help. Finally managed to get it working properly now. I found I was using the wrong post processor once I found the right one, I finally manged to cut out a basic shape. There is quite a learning curve, but I am determined to stay with it.

1 Like