Geeetech A10 - A Beginner's Journey into 3D printing

After more than 4 yrs of owning a K40 laser I’m finally starting a different maker journey by adding a 3D printer to my tool kit. Knowing all the great 3D printing makers on this forum has given the confidence to take on this challenge.

My 3D printer of choice to start with is a Geeetech A10. The one I got was this one from Amazon, which I got a good deal on for Christmas. It’s listed as just an A10 but as best I can tell it’s the same one Geeetech is selling as the A10Pro which is the 3rd version on the A10.

(Edit: I now see that the A10pro is being sold with the GT2560 Ver 4.1b board. This board has A4988 drivers soldered to the board. While this is better for hear management, it does mean you will be stuck with the noiser A4988 drivers.)

The control board is Geeetech’s GT2560 Ver 4.0 and it comes with A4988 Stepstick Stepper Motor Drivers, which I will be upgrading to TMC2208 Trinamic drivers for quieter operation.

Came nicely boxed with a full set of tools, lot’s of extra screws, 4GB micro sd card, and other items.

Since I’ve never set up a 3d printer, I found this video very useful for understanding things to check and adjust during setup.

He appears to have a Ver. 1 of the A10 and the things he identifies as being problematic are addressed in the later versions of the A10.

The printer comes partly assembled so setup was fairly easy. I checked make sure the bed rails were perpendicular with a machinist’s square and only had to adjust them a tiny bit.

Checked the wheels and found them a bit too tight and loosened them just a small amount to get a smooth travel with no looseness to the bed.

Getting all the wiring arranged so it stayed out of the way was a bit of a challenge but I got it done and used velcro ties instead of the plastic zip ties provided.

All set up :tada:

Just prior to getting the printer I had asked about filament recommendations in a different post and was told essentially told to stick to brand name PLA filament to start with :laughing: But other good recommendations about filament storage are also found in the post.


Leveled all 4 corners with the provided “leveling” paper but then found that the middle was a bit bowed up by about 0.16mm relative to the corners.

@mcdanlj gave me a good detailed run down on bed flatness and options to dealing with it. Seems that a 0.16mm deviation might not be that bad for a sub $200 printer with a rolled aluminium bed. I can add a bltouch sensor relatively inexpensively to the printer, but for now I’m just going to level the corners at 0.28mm so the middle comes down to about 0.15mm as a compromise. Will see how that works out. I will also probably be adding a glass sheet to the bed so that could help.


TMC2209 produce less heat than TMC2208 due to lower on-resistance MOSFETs. Especially on step sticks with such limited ability to carry away heat, I’d suggest the 2209s instead. They are only a few $$ more and less likely to cook themselves.

You’ll want to get TMC stepsticks that put the chip on the bottom side of the board and the heat sink on the top, with plenty of vias to carry heat through. You don’t want the heat sink attached to the IC case because that doesn’t conduct heat as well.


Ok, you browbeat, I mean convinced me to get the TMC2209s :wink: They are on the way. Thanks for the advice :slight_smile:


So right after I had the printer setup I really wanted to print something but I hadn’t figured out the whole slicer thing yet. I tried to connect the printer to my computer using Repetier-Host and Repetier Server like Geeetech suggested, but I could not get it to connect. Will play with that later.

The sd card comes with a print file preloaded which is a dog that Geeetech likes to use as a benchy. So I loaded up the sample filament that came with the printer and started the print from the card. 30 minutes in the print failed :cry: MINTEMP Error.

It was late so I said fuck it and packed it in for the night. Next day I downloaded a calibration cube from thingiverse and generated gcode with PursaSlicer on simple mode with default parameters and loaded to the sdcard (wanted something smaller to test). Started the print and it failed again with the same error at almost exactly the same print level.

Did some digging on the error and it seems that it is because there was a bad thermistor reading. In Marlin, MINTEMP seems to be the hotend thermistor while a MINTEMP BED error would have been the one for the bed.

Couldn’t replicate the error by manually moving the hotend around or wiggling the wires. So I unplugged the cable to the hotend and then replugged it to make sure it was fully seated.

Started the print for the calibration cube again and SUCCESS! :tada: Will have to see if this really fixed the problem or if it’s a bad wire that might show up again later.

Seems to be a pretty reasonable print for just using default values. Definitely some parameter tuning and other adjustments to do. Will probably wait until I get the TMC2209s installed, and load up the filament spool I will be using, before doing any more testing.

1 Like

I’m glad to hear that reseating of the cable took care of your issue with the error. I hope that’s all it was.

As for connecting the printer to your computer, make sure you have the correct baud rate set in Repetier-Host.

As you can see by your finished prints, the basic settings are usually pretty good.

I’m glad to see you have successfully completed your first 3D print!

1 Like

Thanks! :blush:

1 Like

Before I switched to hotends with cartridge thermistors, I also had MINTEMP errors when the thermistor was loose in the block. That’s tricky because it needs to be tight enough to be firmly seated, but not so tight that it breaks… It looks like geetech uses bare thermistors. The good news about MINTEMP as an error is that a failing thermistor alone won’t be as likely to start a fire; they didn’t disable the most basic fire protections.

Do consider thermistors, like heater cartridges, to be wear parts. I keep spares around.

Does it use a 12V or 24V power supply?


Enjoy the 3D printing ride !

I did this design many years ago, merry christmas @NedMan !!!

the black one one the photo is ABS with acetone vapor bath 1st and polish with cotton cloth (wet with acetone)


you make me think to update the link (ex G+) in comments here


Good to know, thanks :slight_smile:



Glad to hear it’s 24V — that’s much better in every respect.


It took me a few times when I went down due to a bad thermistor, heating element or clogged tip so now I have a box full of spare parts.


So the TMC2209s will arrive tomorrow and I’ve been doing some reading. So the main thing I understand is that I will need to reverse the motor directions either at the board (swapping wires) or through the firmware.

The question I have is about Vref. I understand Vref limits the current the motors can draw. Should I go with the default values on the chips and see if the motors miss steps or should I target something else initially?

@HalfNormal what did you do with your 2208s?

Post the part numbers printed on the stepper motors and we can look up how much current they are rated for. In general you want to run them at or not too much below rated current in order to have accurate microstepping.

Which 2209 stepsticks did you order?

I got these Bigtreetech ones. Will get the stepper part numbers.

The X and Y motors are 42SHD0278-18A, could not see the one for the Z. Extruder is 42SHD0278-24B1

They say they are rated for 1.0A

There seems to quite a bit of contradictory advice online on how to calc Vref for TMC2209 drivers. I’m not even sure if the 1.0A printed on the steppers is peak or RMS. I can’t find specs for the motors based on the numbers. I guess RMS would be more typical?

@NedMan I’m not at home at the moment but the firmware I flashed lets you pick the type of driver you’re using so that it is calculated in the firmware.

RMS is for AC measurements not DC measurements. The ratings on the motor is one amp DC.

1 Like

Headsmack -well duh lol

Did you use Verts firmware by chance?

1 Like