Gday, I'm really new to this.

Gday,

I’m really new to this. So please point me to the right place if this is ‘one of those’

I’m running a Gshieldv5b - Grbl v1.1f - ChiliPeppr/Grbl (I followed the link)

When I run the homing sequence my machine goes to the home read switches (bottom left up x,y,z).

When I Click start the machine runs out and starts carving into the bed.

I’m guessing that ‘home’ is not 0,0,0 for the ‘job’

I think I’m missing understanding here. I just cant find a ‘dummies’ that’s dummy enough for me.

If someone can help me out, I’ll engrave their name in the bed of my CNC!

:slight_smile:

First, make sure that your X Y and Z shows zero after homing sequence is completed. Check your inches/mm settings.

Now setting Z height:

You should set Z=0 to the top of your material:
Option 1:
Untight the bit in a spindle collet and let it fall down on the top of material and then tight the nut in a collet. Set Z=0 by typing: G28.3 Z0

or

Option 2:
Use and touch probe (connected to A5 and GND on ArduinoUno) or other metal piece of known height and TouchProbe widget to set proper Z height

I Figured it out!
There are a few things
1 - if you refresh it changes the work space.
2 - I when I chose the serial com port I’ve got to chose Grbl from the drop down list. then Tick the serial port (to connect) and wait for the GRBL box above to say… idle.
3 - Check the axes move when you jog (in the preview)
4 - the red and blue line is the 0,0 (so the job will start at 0,0) That’s what the “zero out ‘x/y/z’ axis” does!

and I’m off and calving.