Gcode timeout after 1 hour of generation

LaserWeb information

On the About page, I see that I have:

  • Frontend version: 4.0.998
  • Backend version: 4.0.136
    My settings are:
  "settings": {
    "__version": "4.0.998",
    "__selectedProfile": null,
    "__latestRelease": "2019-11-26T10:42:57Z",
    "showMachine": false,
    "machineWidth": 300,
    "machineHeight": 200,
    "machineBeamDiameter": 0.2,
    "machineBottomLeftX": 0,
    "machineBottomLeftY": 0,
    "machineFeedRange": {
      "XY": {"min": 1, "max": 50000},
      "Z": {"min": 1, "max": 50000},
      "A": {"min": 1, "max": 50000},
      "S": {"min": 0, "max": 30000}
    "machineXYProbeOffset": 0,
    "machineZEnabled": false,
    "machineZMatThickness": 0,
    "machineZToolOffset": 0,
    "machineZStartHeight": "",
    "machineZProbeOffset": 0,
    "machineAEnabled": false,
    "machineBlowerEnabled": false,
    "machineBlowerGcodeOn": "",
    "machineBlowerGcodeOff": "",
    "pxPerInch": 96,
    "forcePxPerInch": false,
    "dpiBitmap": 300,
    "toolGridWidth": 500,
    "toolGridHeight": 500,
    "toolGridMinorSpacing": 10,
    "toolGridMajorSpacing": 50,
    "toolSafetyLockDisabled": true,
    "toolCncMode": false,
    "toolImagePosition": "BL",
    "toolUseNumpad": false,
    "toolDisplayCache": false,
    "toolUseGamepad": false,
    "toolCreateEmptyOps": false,
    "toolVideoDevice": null,
    "toolVideoPerspective": {"enabled": false},
    "toolVideoLens": {"a": 1, "b": 1, "F": 1, "scale": 1},
    "toolVideoFov": {"x": 1, "y": 1},
    "toolVideoResolution": "720p(HD)",
    "toolVideoOMR": false,
    "toolVideoOMROffsetX": 0,
    "toolVideoOMROffsetY": 0,
    "toolVideoOMRMarkerSize": 20,
    "toolWebcamUrl": "",
    "toolFeedUnits": "mm/min",
    "toolTestSValue": 1,
    "toolTestDuration": 0,
    "gcodeStart": "G21         ; Set units to mm\nG90         ; Absolute positioning\nG28\nG0 Z10.0",
    "gcodeEnd": "M5          ; Switch tool offEnd",
    "gcodeHoming": "G28",
    "gcodeGenerator": "default",
    "gcodeToolOn": "G0 Z0.0",
    "gcodeToolOff": "G0 Z2.0",
    "gcodeLaserIntensity": "S",
    "gcodeLaserIntensitySeparateLine": false,
    "gcodeSMinValue": 0,
    "gcodeSMaxValue": 1,
    "gcodeCheckSizePower": 0,
    "gcodeToolTestPower": 0,
    "gcodeToolTestDuration": 0,
    "gcodeConcurrency": 5,
    "gcodeCurvePrecision": 0.4,
    "comServerVersion": "4.0.136",
    "comServerIP": "localhost:8000",
    "comServerConnect": false,
    "comInterfaces": ["USB", "ESP8266", "Telnet"],
    "comPorts": [
        "comName": "COM1",
        "manufacturer": "(Standard port types)",
        "pnpId": "ACPI\\PNP0501\\0"
    "comAccumulatedJobTime": 0,
    "connectVia": "",
    "connectPort": "",
    "connectBaud": "115200",
    "connectIP": "",
    "jogStepsize": 1,
    "jogFeedXY": 1800,
    "jogFeedZ": 300,
    "macros": {
      "*GotoXY0": {
        "label": "Goto XY zero",
        "gcode": "G0 X0Y0",
        "keybinding": "ctrl+f1",
        "_locked": false
      "*LaserOff": {
        "label": "LASER OFF",
        "gcode": "M5",
        "keybinding": "ctrl+f2",
        "_locked": false
    "uiFcDrag": null

Problem description

Hello everyone! I’ve used laserweb in the past to draw SVGs by mounting a pen to my 3D printer and following the gcode toolpaths generated by laserweb. I’ve recently tried to do the same thing but with a much more complex SVG, but my gcode generation consistently keeps timing out after an hour. I looked online to see if I could find anything about this and found this:

I’m not sure whether this timeout is something I can change in settings as I am thinking this gcode will take 3-4 hours to generate, but any help would be much appreciated. If this is something that can’t be changed, does anyone have any other program recommendations that would let me run gcode generation for an extended period of time? Thank you!

  • My computer on which I run LaserWeb runs Windows 10.
    Edit: I should probably add that I am using an ender 3 Pro that has marlin software, and have a gel pen mounted to it that writes around 0.5mm thickness lines.


A very quick suggestion is to check the ‘segmentation’ setting in the job options, lowering this may speed things up.
Alternatively; pre-editing the svg’s in Inkscape to reduce their absolute complexity may help. As may breaking them into individual paths. With very finely segmented paths you can often reduce the overall size and complexity without any discernable effect on the result.

1 Like

Thank you- I actually solved this problem a different way!
I opened up the SVG in a text editor, then manually split it into 3 different parts (just copy pasted 1/3 of the original SVG into a new text document three times.) Then, I loaded it up into laserweb and generated gcode three times for each of the three parts, allowing me to sort of “bypass” the one hour time out. It worked like a charm, as all of the coordinates were preserved this way!