From Repetier Endstops Not Recognized Outside of Homing

Coming from Repetier, I must be missing something. I can setup homing, and it stops at 0. If I run into the endstop after that, it crashes it. It does not stop like homing. I had a situation where I was leveling the bed and was 2mm up on z and decided to move it 10mm thinking it would trigger the endstop. Nope. My z axis got all screwed up and unlevel. So do I need to setup each endstop as a limit switch as well? My understanding is this shuts down the printer. Repetier did not do that. Is there a way around that?

Imported from wikidot

I guess I found my answer: smoothieware dot org/forum/t-1703138.

End stops are only used for homing and limit switches. It’s a bummer that an end stop cannot just freeze movement when triggered.

See :

It is supported, it is the “limit switches” features, it’s just not enabled by default.