Ethernet not working when flashing from sources

smoothie-forum
(pierrex_SW) #1

Hi everyone,

Ethernet works very fine with the official firmware.bin on my SmoothieBoard 5XC, but when I’m compiling Smoothieware from sources, it doesn’t works anymore!

I tried to compile using a fresh Debian install, inside a VirtualBox, but the problem is the same (the board don’t even ping).

I’m doing:

./linux-install
./BuildShell
make clean all
make upload

I also tried to compile the version of Nov 30, (when the last firmware.bin has been updated on GitHub):

git checkout aa1f8bc

When sending @net command from Pronterface, everyting seem to be OK, I have the IP address I configured…

I’m using the default config file, I only changed:

network.enable                              true
network.ip_address                          192.168.0.222
network.ip_mask                             255.255.255.0   # The ip mask

Any clue?

Thank you

Pierre-Xavier

PS: I will share my VirtualBox image on my Google Drive.

Imported from wikidot

0 Likes

(pierrex_SW) #2

Problem solved!

In fact the problem was not related to the firmware version! It’s related to the way I rebooted it! After upgrading with DFU, the board needs to be completly unplugged and plugged again (software reboot is not enough), in order to get the network working properly.

Pierre-Xavier

0 Likes