Error message: Float argument must be a string or a number

I have just saved a simple design in inkscape to a memory stick as normal, when I try to open in K40 I get an error message saying fault. Float argument muste be a string or a number.
Does anybody know what this is about or have an answer please?

Hi Roger,
You need to give us a little more information. What software are you using?


I am using Inkscape, if you have other suggestions, please let me know.

What do you mean by that? I made an assumption that you mean K40 Whisperer, open source software developed by @Scorch since you seemed to have asked about whisperer before. But it’s important to be clear and complete when asking questions in order to get meaningful answers.

You might also attach the SVG you have created that is resulting in this error.

Also say what version of inkscape and whisperer you are using please.

Thanks for your replies, I have redesigned the job and it is now working,I’m sorry if i wasted your time

If you share what the problem was and how you solved it, you will help the next person who runs into the same problem. :slight_smile:

I think the problem was caused by a hidden image in the background which the K40 did not recognise. After I drew the job again and saved it with a different name all was well.


I had the same error, found this thread, and did not find it helpful. However, I solved my problem shortly after, so I thought I would make an account and share my solution in case anyone else ran into this problem.

In my case, I was trying to cut a single line to do a ramp test. I had to create and additional line below my original test line and resize the document in Inkscape with Document Properties > Resize page to drawing or selection. I guess having a single vector line in a file rounds the height down to nothing and gives a null or divide by zero error something.