Eric Lien I recently started using Simplify3d (it's about time,

@Eclsnowman

I recently started using Simplify3d (it’s about time, I bought it months and months ago). My Z direction was not right. When I pressed up on the z axis to make it go up it would go down. It was brought to my attention to swap the wiring on the z axis going to the Azteeg X5 Mini. I did this, but now when I press Z home, it doesn’t go towards the end stop, but up and down are going the correct direction.

Here is the config I have on the X5 mini:

“up” in simplify3d corresponds to an increase in z, which means the bed moves down. If you revert to the original settings you had it is correct

@Zane_Baird Do you think I will just have to remember that up goes down and down goes up then? I don’t see a way to swap the controls in simplify3d.

Since I have the memory card out of the x5 mini, should I update the firmware from 2015 to the latest?

Don’t think about it as up makes the bed go down. Think of it as up increases nozzle to bed distance, down decreases nozzle to bed distance.

As far as upgrading smoothieware, I think it would be a good idea. But keep your old firmware.cur, config, and config-override files. That way if you have anything you don’t like or have problems you can just go back.

Do note that the newer firmware requires the newer config file. It shouldn’t take long to edit it. But just be aware you can’t use old config with new firmware since several things have changed or been renamed.

I messed this thing all up. Argh.

It won’t extrude filament anymore after putting the wiring back to normal.

Any chance you can look this over and see if I have something wrong here.

Why wouldn’t the extruder put out filament?

@Eclsnowman where would I find the new config file to run with the latest firmware version?

i believe if you look at the controls in S3D its non directional but more… graph and plot like. ie + and - as well as number values. as there technically is no “up down left right” its all relative to the extruder i believe and where it moves to.

just think of it as “up” is increasing a gap between the bed and hotend because “up” increases the positive value.

but i myself dont find myself often manually jogging the printer.

@bcrazycramer here: https://github.com/Smoothieware/Smoothieware/tree/edge/ConfigSamples/AzteegX5Mini

(Which version will depend on what version board you have).

You will need to hand edit it. Just open your old config, the new config, and your config override file. It gets pretty clear what needs to be added after that.

Looks like I have the Azteeg X5 mini V1.1. Is there a config file for that? I’m not 100% sure I have my old config file.

I guess maybe that is the config file that isn’t in the V2 or V3 folder. I think my old firmware file is corrupt.

So which firmware version should I run with the V1 config file?

Use the config file in the main folder I linked, not the V2 or V3 folder.

And this firmware (renamed to http://firmware.bin)

https://github.com/Smoothieware/Smoothieware/blob/edge/FirmwareBin/firmware-latest.bin?raw=true

But again, you need to edit it.

@Eclsnowman Thanks Eric. When you say I will need to edit it… Got anything I can compare my config file to? Also what needs to be on the SD card? Just firmware.bin and config.txt?

Yes, http://firmware.bin and the config. I would just compare it to your original config, or the one on the GitHub. Also if you did PID tuning originally then look in your original config-override file. It will have things you modified via gcodes and saved via m500.

Here’s the original config files from the GitHub: https://github.com/eclsnowman/Eustathios-Spider-V2/tree/master/Smoothieware

I’m starting to think there is a problem with my X5 Mini. I don’t see any reason why the attached files wouldn’t allow the extruder to work.

I can test for power if I know what I’m looking for.

Time to get a new X5 mini?

What started the problem again? Because it was working until you tried reversing the z axis correct?