Endstop always triggered. HELP!

My x min endstop is always reporting 1 both through my Viki2 panel probe/status or through a host with M119. I checked my wiring and config. The other endstops are working as expected. I add a pin header to the xmax pins, changed xmin pin from 1.24^ - 1.25^ and I had the same problem? Is something wrong with my board? I have a z probe installed, tried it with Z probe enabled and disabled. Anything else I can check? Thanks for your help.

  1. Endstops

endstops_enable true # the endstop module is enabled by default and can be disabled here
#corexy_homing false # set to true if homing on a hbit or corexy
alpha_min_endstop 1.25^ # add a ! to invert if endstop is NO connected to ground
alpha_max_endstop nc # NOTE set to nc if this is not installed
alpha_homing_direction home_to_min # or set to home_to_max and set alpha_max
alpha_min 0 # this gets loaded after homing when home_to_min is set
alpha_max 375 # this gets loaded after homing when home_to_max is set
beta_min_endstop 1.26^ #
beta_max_endstop nc #
beta_homing_direction home_to_min #
beta_min 0 #
beta_max 375 #
gamma_min_endstop 1.28^ #
gamma_max_endstop nc #
gamma_homing_direction home_to_min #
gamma_min 0 #
gamma_max 300 #

  1. optional order in which axis will home, default is they all home at the same time,
  2. if this is set it will force each axis to home one at a time in the specified order

homing_order XYZ #
x axis followed by y then z last

  1. optional enable limit switches, actions will stop if any enabled limit switch is triggered

#alpha_limit_enable false # set to true to enable X min and max limit switches
#beta_limit_enable false # set to true to enable Y min and max limit switches
#gamma_limit_enable false # set to true to enable Z min and max limit switches

alpha_fast_homing_rate_mm_s 50 # feedrates in mm/second
beta_fast_homing_rate_mm_s 50 # "
gamma_fast_homing_rate_mm_s 4 # "
alpha_slow_homing_rate_mm_s 25 # "
beta_slow_homing_rate_mm_s 25 # "
gamma_slow_homing_rate_mm_s 2 # "

alpha_homing_retract_mm 5 # distance in mm
beta_homing_retract_mm 5 # "
gamma_homing_retract_mm 5 # "

#endstop_debounce_count 100 # uncomment if you get noise on your endstops, default is 100

  1. optional Z probe

zprobe.enable true # set to true to enable a zprobe
zprobe.probe_pin 1.28^ # pin probe is attached to if NC remove the !
zprobe.slow_feedrate 5 # mm/sec probe feed rate
#zprobe.debounce_count 100 # set if noisy
zprobe.fast_feedrate 100 # move feedrate mm/sec
zprobe.probe_height 6 # how much above bed to start probe
#gamma_min_endstop nc # normally 1.28. Change to nc to prevent conflict,

  1. associated with zprobe the leveling strategy to use

leveling-strategy.three-point-leveling.enable true # a leveling strategy that probes three points to define a plane and keeps the Z parallel to that plane
leveling-strategy.three-point-leveling.point1 0.0,0.0 # the first probe point (x,y) optional may be defined with M557
leveling-strategy.three-point-leveling.point2 300.0,0.0 # the second probe point (x,y)
leveling-strategy.three-point-leveling.point3 300.0,300.0 # the third probe point (x,y)
leveling-strategy.three-point-leveling.home_first true # home the XY axis before probing
leveling-strategy.three-point-leveling.tolerance 0.03 # the probe tolerance in mm, anything less that this will be ignored, default is 0.03mm
leveling-strategy.three-point-leveling.probe_offsets 44,0,0 # the probe offsets from nozzle, must be x,y,z, default is no offset
leveling-strategy.three-point-leveling.save_plane true # set to true to allow the bed plane to be saved with M500 default is false

Imported from wikidot

What type of endstop do you have, and how exactly did you wire it ?

mechanical switch type. I wired as instructed in the 3D printer guide. C - Signal , NC - Ground. AHA! Which means I probably have a broken wire (like it says in the guide (love the guides)).
Yup, just tested the Y endstop on the x pins and it works fine.


  • Guy