Does anyone use arduino with grbl 1.1 to control a co2 laser?

Does anyone use arduino with grbl 1.1 to control a co2 laser?

I tried but it proved much easier to go with a smoothieboard. Many more option to control all the peripherals.

I’ve got mine running now. Here’s the high-level list of changes it took:
-added main cutting area door interlock switch in series with laser enable switch (not specific to grbl but basic safety). Flow and temp meter yet to do.
-I’ve also got a relay board for fan and air assist, but that’s not grbl-specific either.
-Connect 24 v from power supply to cnc shield screw terminals.
-Connect 5v from power supply to shield/uno. You may do signal ground too but on mine with the relay board the ground works different to maintain opto isolation.
-Edited the grbl config file for 2-axis homing (default homes Z first which doesn’t exist on the K40) and re-flashed the firmware. The lines are there and you just comment out the original setting and uncomment the ones you want.
-changed my K40’s mechanical NC switches to NO to get homing to work reliably. Adding capacitors might have done the job, and I may try that later.
-$1=255 to keep stepper always energized. Prevents axis drift.
-$3=1 to home at X minimum (left side
-I flipped the stepper connectors at the CNC shield to get proper direction rather than compensate with the $ command
-$21 (I think) to enable hard limits, required for homing to work.
-$22=1 to enable homing cycle
-$27=3mm to move off the switches after homing.
-$100/101, mine needed 158 steps per mm on X and Y.
-X and Y max travel set with $130/131
-I’m still playing with acceleration and max speed, currently at 300 and 50000 respectively .
-jog machine to front left corner and set as machine zero point. There’s a gcode command for this but I used the “set zero” button in universal gcode sender. Machine still homes to the back left, but it sets the right y max.
-$32=1 to turn laser mode on.
-PWM logic inverter circuit (transistor, led and 2 resistors) to compensate for the power supply firing the laser at full power when the PWM signal is 0 volts. I’m traveling at the moment but I’ve got a link to the circuit in one of my other posts.
-PWM signal attaches to pin marked Z end stop on my shield.
-I’ve chosen to leave the original potentiometer in place as a “master power level” control.

I’m up and running with Lightburn software controlling laser power level via PWM. I have to manually start air assist with an M8 command but ever trying else is running perfectly.

1 Like