Delta printer G31 Z-probe fails

Hello All,

I’m running a homebrew delta that originally used a smoothieboard. That died and I switched to Ramps/Marlin for a couple of years until that also failed and I was never happy with the performance/resolution so I switched back to a genuine smoothieboard.

I’ve had FSR sensors under the glass and an FSR controller (GitHub - JohnSL/FSR_Endstop: Force-Sensitive Resistor controller designed for Delta 3D printers for automatic bed leveling) since I built it and they worked great under the first board and the Ramps. But with the new board it’s a crap shoot whether the printer can complete a G31 probe of the glass. Sometimes it completes but more often on one of the ‘taps’ it just grinds down into the glass without seeming to know it touched even though I can see that the led on the FSR controller goes red.

I’ve double checked that nothing else is using the pin (1.28) that the FSR controller is using. I even replaced all the FSRs, controller and cables between everything from the FSRs to the smoothie board.

I’m about out of ideas. Any help?

Randy in Seattle

Have you tried replacing wires between the FSR controller and your smoothieboard? It’s possible that one of the wires was damaged inside moving it from the second failed mainboard to the new smoothieboard…

that was exactly the issue. crimped a new cable and the problem went away. probably didn’t need new FSRs and controller but hey, it works now…

1 Like