curious if anyone has experienced anything like this before.

gplus
discussion
(Jeremy G (WeisTek Engineering)) #1

curious if anyone has experienced anything like this before. new ramps, new screen, new mega. tried on two different screens. running marlin.

since the video is not loading. the controller beeps, and changes from info screen to menu screen over and over.

(david merten) #2

I had the mintemp error when my thermistor wasn’t getting a good electrical connection!

(Jeremy G (WeisTek Engineering)) #3

ya, not the encoder as i have tried it on a known working screen. come to think of it this might be because it is not hooked up to any hardware at all. thermisters included.

ill disable the extruder and bed therm in the firmware reflash and see if it stops. i just wanted the make sure the electronics worked.

(Rien Stouten) #4

I had the same problem some time ago.
Turned out there was a short somewhere in the ramps board/ smart connector… I ended up rerouting the signals from the encoder to other pins and reprogrammed the I/O in marlin. What seeemed to be happening was that the ‘encoder click’ had a short, so the display kept switching.

(Bracken Dawson) #5

The button in the rotary encoder is a direct line to pin 35 on the arduino, so no missing pull ups due to it only being on USB power.

I’d say possibly an issue with the Mega or the code, can you flash another ramps with the same firmware?

PS. Is that RAMPS from Geetech?

(Jeremy G (WeisTek Engineering)) #6

no that is not a geetech ramps. same code I am running right now on my I2. ill have to check the mega. I looked the ramps over the other night ill look again

(Jeremy G (WeisTek Engineering)) #7

going to be on the ramps board or the mega two lcd’s do this one new and one known working lcd.