Controller for 50W Blue laser

Question for anyone that may also have the K50. I think my controller has finally given out on me. The screen never really worked from the time I bought it about a year ago (no info displayed). But I managed to connect it to Lightburn and was controlling everything through that software. But now, when I turn it on…it finds home with no problem, but if I press “pulse” it beeps and doesn’t move. Like I said, the screen display never worked so I’m not sure if it’s throwing up an error anyways. I’ve ruled out the software, because it does that even without sending jobs to the machine. I also know I need to get another controller, at least display, anyways but wanted to rule other issues out while I’m at it. So my questions are…

  1. Would your best guess be that it is the controller or could it be something else?

  2. Do you have any suggestions of a good controller I can buy that would be relatively easy and seemless to install? (replacing the stock Ruida that came with the 50W blue laser)

Appreciate it in advance…

I don’t have this machine so I do not know what the “pulse” function is? Is this all that does not work?
Seems like replacing the Ruida controller and the panel is the easiest route??
I would try and fix or replace the panel first to see it when it works it gives you a hint.

Did you ever try and troubleshoot the panel?
Is this a new machine and the panel never worked?
What symptoms does the panel give?

Hey Don,

The Pulse function is the “Laser Test” button on the K40. Just fires a pulse from the laser. So I guess imagine if that button wasn’t working…when you pressed the laser test button it beeps a few times and doesn’t do anything. Seems like info isn’t even getting to the laser tube. But when I shut it off and restart the laser, it finds home just fine.

I didn’t get a chance to troubleshoot the panel ever…about a week after I got the machine the display stopped showing any data…it’s blank. So I just controlled everything from Lightburn which worked just fine until this issue.

I am leaning towards getting a new controller for it anyways and you’re right I probably have to start there to see if it is throwing any codes or something that I can’t see now. Just wanted to get you guys opinion on if it could be anything else and also other controllers I can get. There’s a few on Light Objects site, but wanted opinions also on which people here have used.

I would replace it with the same ruida controller for a couple of reasons.

  1. The Ruida 6442G that is currently in your laser is a great controller. One of the best out there.
  2. Using the same controller will make installation about a 10 minute process for the physical installation.

You just need to make a backup of the controller settings using RDWorks before doing the swap, that way you will be able to just load all the settings into the new 6442G and not need to do any other configuration.


I suspect the pulse and the homing functions are not related.
Usually there is a function to “Fire” the laser but that usually does not directly involve the controller.
It may be that the pulse is missing a voltage that is also what is creating the dead panel?

Post a picture of the machine and its LPS so we can see what you have.

Does the machine work ok other than the pulse??

We can help you troubleshoot the panel. It sounds like it is missing its DC voltage. Can you also post pictures of it and its connectors? I’m guessing it is the typical panel that is connected to Ruida controllers.

I found this document on controllers showing the HMI connection to the controller.

Hey Don,

I just mentioned the pulse function as a way to rule out the Lightburn software, but it does the same thing even when I send a job over. Once the job is received, and I try to run it…just beeps a few times and doesn’t move. If I don’t send a job over…just boot up the machine and press Pulse…just beeps a few times and doesn’t move. That’s why I suspect the controller.

Still fiddling around with it on my off day and just wanted to keep this up to date.

Just pressed the “test” button on the PS and it did not fire. Seems like I was wrong, looks like the PS is the problem…

yup the test button down on the supply bypasses all controls.