Control issues?

I am new to this lasercutter thing. Bough a morphon k40. Out of the box had to align the mirrors and added air assist . Worked ok, but could not get the target in the center of the head. Noticed a tube mount was broken, so i 3d printed new ones. Added lid safety, ammeter, and a pump interlock. Now the problem. It originally, and is set up ho home back left. When o turn it on, the y axis creeps forward, and the x wont move at all. Using K40 whisperer, i cannot get the x to move at all. And y goes in wrong direction. Cables are plugged in correctly, and just tried a new m2nano board, ssme result. I have a cohesion board coming, but i am thinking i have a problem in the ribbon cable. It is not damaged or creased anywhere. HELP! P.S. the laser fires just fine, and is almost perfectly aligned.

Sorry to hear you are having issues. I no longer have a K40 so I will not be of much help. However @donkjr is our resident K40 expert and I am sure he can help you out. One piece3 of advice i can provide is to get the issues resolved BEFORE installing the Cohesion3D laserboard. That installation will go much smoother if the problems have been eliminated :slight_smile:

That is exactly what i am trying to do. I have determined it might not be a board issue, because i bought an extra m2nano lihiyu? board. I am just about ready to eliminate the ribbon cable, and the stock hall-effect endstops. Ill probably remove all my safety mods and ammeter, but i just cant see how any of tgat would have caused this. #totallylostink40hell

The laser subsystem is a separate subsystem than the motion subsystem so it is highly unlikely that the changes you made are causing your problem.

  1. Has this x-y motion problem always been there i.e. did it ever work correctly?
  2. Do you have and do you know how to use a DVM. If so measure the 24VDC and 5VDC supplies.
  3. Check that the x end stop sensor has not hit the metal flag in the upper left corner of the

Note: Please reference your answer using the question #

Here is some info on endstop problems and wireing:

Please post a picture of:

  • LPS (connector end)
  • The flag in the upper left of the machine
2 Likes

I would also recommend re-seating the ribbon cable on either side and check the small board by the x motor in relation to the metal flag that is intended to trip the optosensor on the board(it slides in the middle of the U part and breaks a beam of light). I would lean towards either the ribbon cable being bad, the middleman board or the motor. I personally added a mechanical endstop and made a new cable for the motor from new wire, but i also replaced my control board with allowed this.

I think i have found the problem. Ribbon cable had a crack in a place it was folded. Found by removing it and checkibg continuity on each trace, 2 were bad. Had to repair it, because i cannot find this cable anywhere.

1 Like

Please let us know if this was the resolution or not. Here is hoping that it was an easy fix and that you will be good to go for your C3D upgrade!

All good now, repired cable and its working fine now.

3 Likes