Config Problem - Machine wont move after homming

Hello, I have a problem with my config file. I’m using de latest firmaware.bin from GitHub repository,
The problem is that when I turn on the machine, the commands to move de the three axis respond well, they move de carriage wher I indicate, then, when I sen the homming command, the machine goes to homming position with no problem, but after that, the only movement that the machine accepts It’s homming position again, and no other command, I mean, I can’t move de carriage anywhere with the commands from my TFT screen and only works the homming position command… any Idea?

To add more mistery to this issue, if I move to homming position each axys individually, then I can still move the carriage where ever I want, but, if I hit the homming position command for all three axys at once, then, I’m only able to move to home position all the three axys again, but can not move anywhere…

This is the config for the endstop module that I’m using…can you see any issue there?

#################################################################################################################################
# Endstops.   See http://smoothieware.org/endstops

endstops_enable                              true             # The endstop module is enabled by default and can be disabled here
corexy_homing                                true             # Set to true if homing on a hbot or corexy
alpha_min_endstop                            1.24^!            # Pin to read min endstop, add a ! to invert if endstop is NO connected to ground
#alpha_max_endstop                           1.25^            # Pin to read max endstop, uncomment this and comment the above if using max endstops
alpha_homing_direction                       home_to_min      # Or set to home_to_max and set alpha_max and uncomment the alpha_max_endstop
alpha_min                                    0                # This gets loaded as the current position after homing when home_to_min is set
#alpha_max                                    300              # This gets loaded as the current position after homing when home_to_max is set
beta_min_endstop                             1.26^!            # Pin to read min endstop, add a ! to invert if endstop is NO connected to ground
#beta_max_endstop                            1.27^            # Pin to read max endstop, uncomment this and comment the above if using max endstops
beta_homing_direction                        home_to_min      # Or set to home_to_max and set alpha_max and uncomment the alpha_max_endstop
beta_min                                     0                # This gets loaded as the current position after homing when home_to_min is set
#beta_max                                     300              # This gets loaded as the current position after homing when home_to_max is set
gamma_min_endstop                            1.29^!            # Pin to read min endstop, add a ! to invert if endstop is NO connected to ground
#gamma_max_endstop                           1.29^            # Pin to read max endstop, uncomment this and comment the above if using max endstops
gamma_homing_direction                       home_to_min      # Or set to home_to_max and set alpha_max and uncomment the alpha_max_endstop
gamma_min                                    3                # This gets loaded as the current position after homing when home_to_min is set
#gamma_max                                    400              # This gets loaded as the current position after homing when home_to_max is set


soft_endstop.enable         true         # Enable soft endstops
soft_endstop.x_min          1            # Minimum X position
soft_endstop.x_max          300          # Maximum X position
soft_endstop.y_min          1            # Minimum Y position
soft_endstop.y_max          300          # Maximum Y position
soft_endstop.z_min          1            # Minimum Z position
soft_endstop.z_max          400          # Maximum Z position
soft_endstop.halt           false         # Whether to issue a HALT state when hitting a soft endstop (if false, will just ignore commands that would exceed the limit)


alpha_max_travel                             300              # Max travel in mm for alpha/X axis when homing
beta_max_travel                              300              # Max travel in mm for beta/Y axis when homing
gamma_max_travel                             400              # Max travel in mm for gamma/Z axis when homing

### Optional enable limit switches, actions will stop if any enabled limit switch is triggered
#alpha_limit_enable                          false            # Set to true to enable X min and max limit switches
#beta_limit_enable                           false            # Set to true to enable Y min and max limit switches
#gamma_limit_enable                          false            # Set to true to enable Z min and max limit switches

### Endstops home at their fast feedrate first, then once the endstop is found they home again at their slow feedrate for accuracy
alpha_fast_homing_rate_mm_s                  50               # Alpha/X fast homing feedrate in mm/second
alpha_slow_homing_rate_mm_s                  25               # Alpha/X slow homing feedrate in mm/second
beta_fast_homing_rate_mm_s                   50               # Beta/Y  fast homing feedrate in mm/second
beta_slow_homing_rate_mm_s                   25               # Beta/Y  slow homing feedrate in mm/second
gamma_fast_homing_rate_mm_s                  4                # Gamma/Z fast homing feedrate in mm/second
gamma_slow_homing_rate_mm_s                  2                # Gamma/Z slow homing feedrate in mm/second

alpha_homing_retract_mm                      5                # Distance to retract from the endstop after it is hit for alpha/X
beta_homing_retract_mm                       5                # Distance to retract from the endstop after it is hit for beta/Y
gamma_homing_retract_mm                      1                # Distance to retract from the endstop after it is hit for gamma/Z

The only difference that I can see from my config file is that I have
#corexy_homing false
My machine is a standard X Y Z configuration.
I have no idea what corexy or hbot homing is.
You could try taking that command out with a #
I note that you have inverted all your end stops with !. and you have them as pull up with ^.
You could try removing the ! (Un-inverting the pin). You can find all this information in the "Configuring-smoothie " file which I think is in the Github repository.

the corexy homing option is commented, so don’t worry about this.

it sounds like you are going into alarm mode
please connect to the machine with pronterface, and it should hide any alarm messages where your current host might be hidding them

also try sending M999 to clear out the alarm mode after homing and see if that helps you move again ( even if it doesn’t actually solve the issue ).

The config printed out has corexy homing as true. That’s why I suggested he comment it out.
I never did get to grips with the limit/homing and max limit switches. So I don’t have my max stops enabled as it seemed to do strange things with homing. I gave up in the end.

sorry my email client somehow showed another version of the config…
yes, if this isn’t a corexy, this should be commented. it’s unlikely to be the issue though, the effects would be different