Compiling grbl-lpc on Windows I'm starting to test out grbl-LPC and wanted to compile

(Jim Fong) #1

Compiling grbl-lpc on Windows

I’m starting to test out grbl-LPC and wanted to compile my own version.
This is how I did it and is not necessarily the correct way. I used a new windows virtual machine so not to mess up my existing build environment. You can use Virtual box, Vmware, Windows Virtual PC etc.

Install git

Install make

Install GNU ARM Embedded Toolchain (I used the Windows 32bit .exe version)

Set your Windows PATH to include the git,make and ARM toolchain
This is what my PATH is set to…
PATH=C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Program Files\Git\cmd;C:\Program Files (x86)\GnuWin3
2\bin;C:\Program Files (x86)\GNU Tools ARM Embedded\6 2017-q1-update\bin

Open a Windows Command shell

Download the grbl-LPC source code. I used cprezzi fork
git clone

If you want to download the 4 axis branch version
git clone -b more-axis

Change directory to the downloaded source code, should be \grbl-LPC

Run these comands in the following order
git submodule init
git submodule update

If all goes well, there should be a firmware.bin in the \build directory.

Edit \grbl\config.h if you need special version such as coreXY

(Todd Fleming) #2

It is the correct way. Unfortunately a VM is the way to go since toolchains under Windows have a nasty habit of conflicting with each other.

(Arion McCartney) #3

Thanks for sharing that!!

(Tony Sobczak) #4


(Tony Sobczak) #5

@Jim_Fong What do I modify to change the followinh:


(Jim Fong) #6

@Tony_Sobczak you need to modify /Grbl/defaults.h file with your new parameters and re-compile with the above instructions.

The settings are under DEFAULTS_K40

(Jonas Concepcion) #7

Thank you for sharing this. I got as far as the “make” command but it came back with an “Error 2” cannot find the file specified (seems to be coolant_control.o) this was with both the master and the 4axis variant.

Any insight? Sorry I do not know enough on what other relevant details provide. below is as far as I got.

(Claudio Prezzi) #8

@Jonas_Concepcion Did the steps “git submodule init” and “git submodule update” complete without errors?

(Claudio Prezzi) #9

@Jonas_Concepcion You could also try to start a normal shell as administrator to execute “make”. On my system, it works with the normal shell but not with the git bash (did not try the power shell).

(Claudio Prezzi) #10

Ok, I can confirm that it also works with power shell on my system.

(Jonas Concepcion) #11

Thanks so much. I was able to get it work on a different pc. It’s possible that I needed to use the unsigned ARM toolchain vs the one for windows 7 and above.

final question. Is there still 2 versions of this one for 4 axes and one standard as Jim Fong notes in the original post which is the latest git to clone?

(Jim Fong) #12

The 4 axis version got moved to the master branch. So just clone or download the master.