Cohesion laserboard ethernet smoothieware

So I have a cohesion board which got destroyed in a power bump along with a Duet3 board. Not a good day. In order to finish some work I needed to get the system up and running quickly so I used a MKS sbase 1.3 board I had laying around. I had a USB over rj45 extender which I had attempted to use with the c3d board. the c3d board consistantly would not respond when using the extender. My computer saw the board and it would respond with appropriate responses to M119 and M503 commands. Attempt to start a print and it would fail on homing. Attempt to home and it would fail and lock. When I installed the MKS board I tried the extender and imagine my surprise that it worked flawlessly. Even when I plugged in the usb camera, everything worked. This leads me to believe that the c3d USB implementation is bad. Supposedly, the ethernet connection is flaky as well, with the blame being placed on smoothieware and the updating of the memory card. Would I be wrong in thinking that it’s more than likely a bad implemention of the ethernet port on the c3d board instead? I don’t know of anyway of testing the ethernet port with lightburn… Does anyone know how to enable the ethernet port in lightburn for smoothieware?

1 Like

Ethernet on a C3D board is not supported by LightBurn, the developers were never able to get a reliable, long lasting connection. It is not due to the hardware design of the board AFAIK.


and yet we use smoothieware and smoothieboards on 3d printers. I’m currently in the middle of a 16 hour print. seems to me that someone is covering there *ss somewhere.

But you are not streaming the Gcode to the Smoothieboard, you are loading it all first, then printing.