ChiliPeppr  problem sending Gcode - Troubleshooting help?

@ChiliPeppr problem sending Gcode - Troubleshooting help?

I’ve had good luck using Chilipeppr previously with my TinyG driven Sherline, but as of today, I’m somehow unable to run Gcode files properly. I can jog, manually run Gcode commands, and run Gcode files through the simulator, but when I try to send them to the “serial port” (using the Gcode widget), it just runs through the commands all at once without anything actually getting sent to the TinyG. If I click on single lines in the Gcode widget they seem to send fine, but it won’t run the full files, even ones that it has run previously. These same files seem to run fine through CoolTerm and tgFX also by the way.

I’ve tried resetting the TinyG, the json server and ChiliPeppr but without getting anything different. I’ve also tried changing the Pre-Uploading settings and using Multi-Line Mode with a few different settings but also with no difference. Anyone have any other suggestions for what I might try?

You sure you are running SPJS v1.7? The Gcode widget now uses the /jsonSend command instead of /send so it gets events back onWrite/onComplete.

And are you connecting to your TinyG with the “tinyg” buffer chosen in the pulldown menu for the serial port item you are selecting?

The serial port console in the lower left also now uses /jsonSend and will put a checkmark next to your manually typed Gcode and it should go from yellow, to blue, to black as the events come back. That will happen so fast that really you’ll only notice the checkmark go black.

@jlauer Updating to json 1.7 did it. Thanks as always! Now back to some machining… :slight_smile: