Chilipeppr.com will not appear on Chrome for me.

Chilipeppr.com will not appear on Chrome for me. Chrome is saying that the site is not secure and is recommending to add “https:” in the address bar. This doesn’t work either. I did install an antivirus software but it is not running. I’ve cleared the history and cache from chrome but still not working. Any input would be greatly appreciated.
http://Chilipeppr.com

“A picture is worth a thousand words” I’ve tried everything. Re-installed Chrome twice, run several antivirus softwares, turned off all Windows 10 built in web protection. What am I missing? Help!

And…chilipeppr will load in Microsoft Edge Browser, only after refreshing the page?

Still dealing with this issue if anyone can help?

You probably have some kind of ad-blocker turned on and it’s blocking ChiliPeppr because it uses Google Analytics.

You can look at the Javascript console to see where the error is on load.