Can't seem to wire my z-probe right...

I’m pretty concerned about the lack of documentation on this topic….

My current wiring is at
. com

the z probe detects metal (light gets brighter) but in pronterface when I type M119 I get “Probe:0” even if the light is bright


Imported from wikidot

It’s wired wrong. The general wiring is like this chart. There may be some nuances depending on your sensor (what voltage rating and if it’s open collector or (?)). Not sure what you’re trying to do with the resistors, drop the voltage down?

Sensor -- Smoothie
Blue = Ground -- Blue
Black = Vcc -- Red
Brown = Output -- Green

Did you ever figure this out? I have the probe working in the sense that the red light comes on when it senses the bed but smoothie does not recognize that it is getting a signal I think.

I have wired it up with the 10k and 15k resistors and verified that it is getting 3.3v and not the full 12v back to the board.
Here is how I have it wired:
http ://s653.photobucket .com /user/cdl1701/media/20160326_131530_zpst28juozx.jpg.html
Sensor on the left and power supply (12v) and SB on the right. Dotted lines represent the Zmin plug on the board with the color designations coming from the 3D printer guide for endstops.

Here is my config:

endstops_enable true # the endstop module is enabled by default and can be disabled here
#corexy_homing false # set to true if homing on a hbit or corexy
alpha_min_endstop 1.24^ # add a ! to invert if endstop is NO connected to ground
alpha_max_endstop 1.25^ # NOTE set to nc if this is not installed
alpha_homing_direction home_to_min # or set to home_to_max and set alpha_max
alpha_min 0 # this gets loaded after homing when home_to_min is set
alpha_max 200 # this gets loaded after homing when home_to_max is set
beta_min_endstop 1.26^ #
beta_max_endstop 1.27^ #
beta_homing_direction home_to_min #
beta_min 0 #
beta_max 200 #
#gamma_min_endstop 1.28^ #
gamma_max_endstop 1.29^ #
gamma_homing_direction home_to_min #
gamma_min 0 #
gamma_max 140 #

  1. optional order in which axis will home, default is they all home at the same time,
  2. if this is set it will force each axis to home one at a time in the specified order

#homing_order XYZ # x axis followed by y then z last
#move_to_origin_after_home false # move XY to 0,0 after homing

  1. optional enable limit switches, actions will stop if any enabled limit switch is triggered

#alpha_limit_enable false # set to true to enable X min and max limit switches
#beta_limit_enable false # set to true to enable Y min and max limit switches
#gamma_limit_enable false # set to true to enable Z min and max limit switches

alpha_fast_homing_rate_mm_s 50 # feedrates in mm/second
beta_fast_homing_rate_mm_s 50 # "
gamma_fast_homing_rate_mm_s 4 # "
alpha_slow_homing_rate_mm_s 25 # "
beta_slow_homing_rate_mm_s 25 # "
gamma_slow_homing_rate_mm_s 2 # "

alpha_homing_retract_mm 5 # distance in mm
beta_homing_retract_mm 5 # "
#gamma_homing_retract_mm 1 # "

#endstop_debounce_count 100 # uncomment if you get noise on your endstops, default is 100

  1. optional Z probe

zprobe.enable true # set to true to enable a zprobe
zprobe.probe_pin 1.28^! # pin probe is attached to if NC remove the !
zprobe.slow_feedrate 1.5 # mm/sec probe feed rate
zprobe.debounce_count 100 # set if noisy
zprobe.fast_feedrate 20 # move feedrate mm/sec
zprobe.probe_height 5 # how much above bed to start probe
gamma_min_endstop nc # normally 1.28. Change to nc to prevent conflict,

  1. associated with zprobe the leveling strategy to use

leveling-strategy.three-point-leveling.enable true # a leveling strategy that probes three points to define a plane and keeps the Z parallel to that plane
leveling-strategy.three-point-leveling.point1 20,5 # the first probe point (x,y) optional may be defined with M557
leveling-strategy.three-point-leveling.point2 180,5 # the second probe point (x,y)
leveling-strategy.three-point-leveling.point3 180,140 # the third probe point (x,y)
leveling-strategy.three-point-leveling.home_first true # home the XY axis before probing
leveling-strategy.three-point-leveling.tolerance 0.03 # the probe tolerance in mm, anything less that this will be ignored, default is 0.03mm
leveling-strategy.three-point-leveling.probe_offsets 24,0,0 # the probe offsets from nozzle, must be x,y,z, default is no offset
leveling-strategy.three-point-leveling.save_plane true # set to true to allow the bed plane to be saved with M500 default is false