Can't grayscale

I’ve built a pen plotter and succesfully used laserweb so far. Now I fitted it with a laser.
I’m trying to do a simple test to burn a cube at 10%, 20%,… of the laser power. My produced gcode always uses max power (M3 S1000).

Hardware: arduino uno, CNC shield, GRBL.
Laserweb 4.0.998 config: I set laser power from 0% to 100%, disabled “burn white”, set the grayscale to average, set Shades to 10.
“Show Documents” displays the image correctly. Tweaking contrast and gamme gives a correct change in the image. “Show laser” also shows a correct image.

Is there something obvious I’m missing?

Couple of questions :

What laser are you using?

How is it wired ?

Could you post pictures so I can get a better idea of what you have ?

I’ve done this, without the CNC Shield, I can probably bottom this out for you.

well, PWM works alright. I just can’t see how to change the strength according to grayscale.


Can’t help without the info I asked for.

Maybe someone else.

Ehm. It’s wired to 12V and the PWM pin goes to the Z+ limit switch, which is the PWM pin of the arduino.
LaserGRBL can simply control the laser with M3 S1 to S1000. I’m trying to cut a simple square now, and I can’t vary the power either.
“Laser test” doesnt do anything. Pen up/down turns the laser on and off.

Do you use a special servo version of GRBL?
RC servos are not realy PWM controlled, they accept puls durations in the range of 0.5 to 2.5ms. Therefore a special version of GRBL is needed for servo control, and this version is not compatible with Lasers.

PS: The “Laser test” feature in LaserWeb might be broken.

I think I tried a modified servo version before. GRBL recently reflashed with the latest version from the master branch.
I’m using an arduino nano to convert the PWM signal to a stepper servo, when using the pen module. For the laser, it just connects to the PWM signal.

The link you posted was from LaserWeb1, which is deprecated and not supported anymore. Which version did you try?

LaserWeb4 needs at least GRBL version 1.1h. Only versions above 1.1 support LaserMode, which we rely on.

Laserweb 4.0.998, grbl 1.1h

This problem seems to be solved now:

1 Like