Can't access Tools in Settings tab

I’ve got Laserweb4 installed on a Raspberry Pi and it seems to be working (no serial device to connect to as I’m still testing priot to installing for a K40 at the local maker space)
I can create a new machine profile but I can’t save it - the Tools option under the Settings tab does not respond. I’ve tried this with Chromium from both the Raspberry Pi and my desktop (Ubuntu) with no success. I don’t want to do the upgrade from LW3 until I sort this out.
I can’t find anyhting similar listed online.
EDIT: I have cleared the cache in the browser.

OK, if I access the server from the Raspberry Pi via localhost:8000, I can get the save/restore settings under Tools. If I access the server via its host name i.e. raspberrypi.homelan:8000, I don’t get to save/restore settings. Network is OK because I can access the server via hostname. I get the same lack of save options if I connect via ip address. It’s only if I point the browser at localhost or that it works.

[Found same error reported - no fix suggested]

1 Like

A bit more testing:

If I install the LW4 frontend on my desktop (Ubuntu 19.10) and access the LW4 server on the Pi, it works as expected ie. I can load/save configuration files.
It’s only when using the browser (Chromium or Chrome) on the desktop that it fails.

Please use newer topic:

[This thread?]
I did manage to get the gh-pages branch of LW4 you pointed me at, into but they made no change to the problem.

This is the topic I started. I linked it into the older thread when I found it. I’ve answered in that thread because that’s where the responses appeared. That other thread was started over 6 months ago.

It just doesn’t make sense to answer in this topic to a discusson we had in the other topic. This topic can be deleted, because all usefull information is in the other topic.