Cannot open Illustrator/Inkscape SVG in K40 Whisperer (solved)

My file looks perfect in both Illustrator and Inkscape. I can’t get it to open in K40 Whisperer, though. I get the error, “Inkscape Execution Failed (while making raster data). Inkscape sub-process terminated after 180 seconds.” The file consists of some jigsaw puzzle piece objects that I created that have a pattern fill on them. I have tried with all sorts of SVG options and formats and done everything I can think of in Illustrator to simplify the objects. The error makes it sound like it’s working fine, just timing out. However, my CPU usage is very low, so I don’t think that is the actual problem.

I can open other SVG files in K40 Whisperer without issue.

This is what the error looks like:

This is the SVG: Dan jigsaw - pieces 3.svg - Google Drive

Any ideas?

FYI it’s easier for folks here to see if you just upload the png and svg directly here. Just click the image button to upload.

K40 Whisperer uses inkscape so I would see if maybe you have 2 versions and it’s loading a different one than you have run.

It is probably also using commandline features which might be causing the problem. I would also look at starting K40 whisperer from the commandline and see if there’s more info on the problem. See if there’s a way to enable more debug messages too.

That error usually means that the file is too large and rastering it took too long.

You can increase the time limit over in Settings → General Settings → Inkscape Timeout. The default is 3 minutes.

Exporting large high-DPI images in Inkscape (this is what K40 Whisperer is doing) is pretty slow.


I will definitely do that next time. Thanks!

1 Like

That was it. 5 minutes was enough. Thanks!