Cannot install K40 Whisperer libusb/ Y axis grinding

Hello guys,

New K40 owner here but I have two issues from the get go: First: is the Y axis grinding in a neverending roll, and the second is that I cannot install K40 Whisperer libusb, I have tried with both K40 default installer but nothing appears in the list and Zadig but only my webcam and Bluetooth controllers are available.
I have attached pictures that might help but I am not sure how can I troubleshoot or test the M2Nano board in case of failure, By the way the Y stepper is disconnected to stop the annoying noise because I suppose with K40 Whisperer I can control it in the future.

Can you help by any chance? I have checked multiple similar topics but to no avail.
Many thanks!
.

Can you please post a video of this action.

Does it do this at startup, randomly only with a running job etc?

Is this a new problem or has this been doing it from the start?

Is there a reason the connector in the bottom left of the second picture is not connected? I believe that is your end stop power connector. It should connect to the connector on the right side of the m2Nano board.

1 Like

I am guessing this is why?

3 Likes

Both X and Y end stops and the X stepper run through the flat ribbon cable, which he still has connected. As the OP said, he unhooked the Y stepper (that 4 wire that you see), so keep it from deading out.

Seems like the optical end stop isn’t aligning right, I’d start looking there (end stops are both at the left side of the gantry, above the Y stepper. I could give more details/photos tonight. @AlexMD This is a brand new machine? So the end stop has never worked from the start?

It likely is the endstop thats the reason for the questions :slight_smile:

I really should learn to read! Pictures just don’t tell the whole story anymore!

1 Like

I have received it today in fact and that’s why I am a bit dissapointed. I will check the endstop maybe there’s something with it (x axis it seems is working just fine). What are the signs for a dead motherboard, is it possible for an endstop not to actuate be an actual sign for example?

It is at startup, unfortunatelly no job yet; when should be homing, it seems like Y is not finding an endstop . I am new with laser machines (this is my first) so I am trying to do a parallel between this and my 3d printers.

The K40 typically uses optical end stops for homing.

Here is were you will find the y endstop.

Make sure the metal tab in the back of the machine is not bent and is sliding into the slot in that endstop sensor. Also make sure the white ribbon cable is well seated on the control board and the board that sensor is attached to.

1 Like

I doubt it’s your motherboard. Rather the daughterboard on the Y axis optical sensor, as @nedman just posted.

Take a look at the blog posts I referenced in my last post.
In shipping, it’s common for the tab to be misaligned or to impact the optical sensor and damage it.

Please post a picture showing your end-stop and its interposing tab…

Earllier questions unanswered;

1 Like

Hello,
I have checked the endstop and the piece of metal that comes into contact, and it was bent it is also a bit too thick, i bent it back and now it is working but scrapes when comes into contact, I will check if I can replace it or file it down a bit but it works for the moment.
About the motherboard, I have tried yesterday with my laptop Win10 and my fiance’s Win8 for 3 hours and nothing. This morning I just started the machine, to check your recommendations (and bent back the piece of metal) and it just booted. No wiring change, nothing, connected, used zadig and found the device and I have installed the driver. I cannot explain that.


I will start some tests and i hope these were all the issues with the machine, I am thanking all of you for your help.

Thank you!

2 Likes

I recommend you adjust/modify the tab so that it does NOT contact the optical sensor.
Those sensors are easily broken and if it breaks there is no replacement part only manual repair.

3 Likes

Yeah that’s a pretty thick tab.