Can someone help me? I can't figure this out for the life of me.

@Yves_BAZIN That fixed the multiples in a row, Thank you!!! Do you have any thoughts on how I could make the colors move/cycle? I would like the option to set 1 effect to be solid, and one to cycle

@Kyle_bostick in you main loop you have
if (setEffect == “C9”) {
FillLEDsFromPaletteColors( colorIndex);


Do this instead
if (setEffect == “C9”) {
FillLEDsFromPaletteColors( colorIndex);

@Yves_BAZIN You are awesome! thank you soooo much for all your help!

@Kyle_bostick ahah you are welcome. Now we want to see a nice video of your build :wink:

I will post one soon! I have one other issue i am working on, its an Arduino issue, trying to figure out why OTA is not working.

@Kyle_bostick which board do you have ?

D1 Mini, So what happens, I go to Tools > Port select my Board from the list of networks and click upload, it does verify and compile it, i then get a pop up asking for my OTA password. I enter the pw and the box goes away for a split second and pops back up asking again. I am 100% sure i am typing the pw correct. I have tried to change and remove it as well, same result

@Kyle_bostick have you tried OTA without password first

Update, I can upload OTA to some of my D1 Mini’s. I do not understand. I copied the sketch and changed the device name, and the MQTT topic names, the rest of the code is the same. Some work, some say “auth failed” but the password is the same on all of them. I have tried to remove the password, it does not help

@Kyle_bostick when you compile your program how much memory does it take

missing/deleted image from Google+

@Kyle_bostick Humm normally you should have enough memory. Can I see the code ?

@Yves_BAZIN its the same code that you have been helping me with. What is weird is it works on some of my D1 Minis, but not others. I have several all the same model, and ordered at the same time, flashed with almost identical code, but the names of the devices is different. some work, some don’t

@Kyle_bostick I will have a look at it and test it on my esp8266 I don’t see any mistake with the code

@Yves_BAZIN I wanted to update ya, I have no idea why, but the issue is the name of the OTA device. I have changed the names around, and then it works. 1 of the boards will not accept the password, but the rest of them work after changing the OTA names. Thank you so much for your help. I am waiting for a few more sets of LEDs in the mail, once I get them wired up I will post a video

@Kyle_bostick good news !!! Good luck with the rest


@Yves_BAZIN Thanks a million, everything is up and working! I could have never finished it without your help!

@Kyle_bostick you are welcome !! Great job with building all that !!!